Kawasaki ZX-10R Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello, firstly I would like to thank you the welcome on this Zx forum, writting from Spain.

I just bough in USA a petrol tank for my zx10R 2006, and the model received is for the "USA california" zx10 model, that is lightly different from the "regular & European" tank.

The california has 2 more hoses: fuel return hose and fuel tank breather hose.

My simpley question is if someone could help and explain me if is possible to fit the California tank model on the regular model, and how to do that.

Do I need to close these 2 extra hoses and that's all?
Is it imposible to fit the california model on the regular model?

Thank you very much for your help, I'm lost... :-(
 

·
Registered
Joined
·
753 Posts
Hey man. welcome :hello:

You probably already know this but the -main-fuel hose to the common rail is the one coming out of the fuel pump.
If you have another hose pouring fuel out just block it in an absolutely secure way.
DO NOT plug the breather hose that goes to the fuel cap area or water may enter to the tank in the event that you wash the bike or ride in the rain.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Hi, thannks a lot for the help, I have the main hose going out for the fuel pump, another hose for the "extra fuel" goping out in the case is over fill, and the california model has 2 more hoses, one is Fuel return and the other Fuel tank breather.

So, if I close both (return and breather), will I have any proble of tank working?
 

·
Judge Dredd Mod
Joined
·
9,188 Posts
Dont plug the breather hose. Just plug the second fitting (I used a rubber fuel plug secured with a clamp) and you'll be fine. If you plug both you may run into a problem where the fuel is pumped out and no air can get in causing the tank to deform.
 

·
Registered
Joined
·
753 Posts
By looking at the diagram I guess both extra vents may be left opened, as both go to the fuel cap area.
Just rooting a hose from both of them down to the lowers of the bike seems fine enough.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #6
It is right that both goes to the top of the tank, but the breath(blue) goes to the fuel cap level and there is a hole on the top of the fuel cap narea to drop the over fuel, the other, the "fuel return"(red) goes to the top, but I don't see any hole on the tope, so probably the exit of the hose is between the internal layer of the fuekl tank and the area of the fuel cap.

In summary, I can plug a tube to the breather and bes used as a conduct for over fill.

But what happen with the "fuel return", I close it? or a plug a tube?
 

·
Registered
Joined
·
753 Posts
I'd plug a hose there too. Looks like that if you overfill the tank, the excess will be drained down that hose first, not the breather.
 

·
Guilty by association
Joined
·
8,751 Posts
yea you need the breather, but only the one fuel line
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Done and working perfectly, thank you vey mcuh for your help. Great community :thumbsup:
 

·
Registered
Joined
·
2,658 Posts
Old post i know, but not clear enough...
I've just got a CA tank and want to know what to do:

On which color to connect a hose?
On which color to block?
Connect them together?

Tx!
 

·
Registered
Joined
·
890 Posts
Sorry to thread jack but I have an opposite scenario. Just purchased a non CA gas tank for my CA bike. Anything I should be aware of in order to make it work without any problems? Thanks. BTW it's a gen 3
 

·
Registered
Joined
·
6,028 Posts

·
Registered
Joined
·
890 Posts

·
Registered
Joined
·
6,028 Posts
Thanks man. Been a while, how have you been? So am I right in thinking that there should be no problem putting on a non CA gas tank as long as I get rid of the Kleen air system? Thanks.
Good man. Nothing crazy, but doing good this far.

As far as your bike, I know that worked on my Gen 1. If you look, you should only have to plug the throttle body ports that would go to the KLEEN system.
 
  • Like
Reactions: tasos and wunnam

·
Registered
Joined
·
890 Posts
Good man. Nothing crazy, but doing good this far.

As far as your bike, I know that worked on my Gen 1. If you look, you should only have to plug the throttle body ports that would go to the KLEEN system.
That's pretty straight forward. Thanks man. Rep sent.
 

·
Registered
Joined
·
6,028 Posts
1 - 17 of 17 Posts
Top