Kawasaki ZX-10R Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I have done them b4 but Dont know whats goin on this time guys, They compress when i put the bike down off the stand but after that they r hard as a rock :sad: any ideas??
 

·
Registered
Joined
·
376 Posts
ive never had any problems when i rebuilt mine. i used an oil level gauge that has a syringe to suction any extra oil out and to make sure the oil was the right height. took me a few tries to get the rebound adjuster cap set to the right depth on the piston rod if you know what im talking about. :dontknow:. after i got it set right the fork worked fine.
 

·
Registered
Joined
·
469 Posts
yeah i don't even use a measuring cup, u need to set the correct height!

AND FYI - Every company's fork fluid weight is different, motul 5w is a lot different from Bell Rays 5w
 

·
Registered
Joined
·
376 Posts
yeah i don't even use a measuring cup, u need to set the correct height!

AND FYI - Every company's fork fluid weight is different, motul 5w is a lot different from Bell Rays 5w
Hmmmm this kinda makes me wonder. I have Honda Showa oil in one fork and Don't know what's in the other. :dontknow:.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #7
ive never had any problems when i rebuilt mine. i used an oil level gauge that has a syringe to suction any extra oil out and to make sure the oil was the right height. took me a few tries to get the rebound adjuster cap set to the right depth on the piston rod if you know what im talking about. :dontknow:. after i got it set right the fork worked fine.
Ok thats a new 1 to me. Rebound adjuster cap????
 

·
Registered
Joined
·
41 Posts
Discussion Starter #13
Me being dumb and forgetting stuff. Didnt turn the adjusters all the way in b4 i put it back together so i spent 3days of pulling my hair out on 1 and 45min's on the other 1 ;( Sorry guys if i took up ur time..
 
1 - 14 of 14 Posts
Top