Kawasaki ZX-10R Forum banner
1 - 16 of 16 Posts

·
Speed Freak
Joined
·
12,730 Posts
Discussion Starter · #1 ·
If you have the rev extend and you un-install the ignition module make sure you disable the Rev extend feature!!! if not a CPS code will be thrown on the pc3 I think device error 69... It makes the bike have a stumble around 4-7k rpm!!! I called up power commander and they couldnt figure out why it was happeneing, i even ohmed out the CPS and even swapped the harness on the TB's but while i was just thinking about it the other night i remebered i had that rev extend enabled. Disabled the rev extend and it purs like a kitten! :thumbsup:
 

·
Registered
Joined
·
60 Posts
rev extend

we run a pciii and rev extend in a mini sprint . the other day we cut the triger wire on the ign moduel and removed it from the car. the darned thing goes out and falls on its face about every other start from aprox 4000 rpm's.we have repaired the ign mod and reinstalled but it still screw up. also sometime the ign moduel turn on and sometimes it doesn't. do you have any other info thanks dad
 

·
Registered
Joined
·
51 Posts
I couldn't get the ignition module to work on my car either. It would be fine for about 5-6 laps then the motor would start breaking up and communication light would go red.
I only pulled the plug, but it didn't effect anything. Well, the motor stays between 8000-rev limit so I probably wouldn't notice it.

Very disappointed in the module. Never even got the rev extend to work and from what I have heard that is the norm.
 

·
Registered
Joined
·
60 Posts
jeff
have you called people at dyno jet they helped us. did you get code from them to extend rev? our's worked fine until i cut the wire turn out it is coax and i didn't make good ground on outer covering.
 

·
inappropriate
Joined
·
7,728 Posts
This is good for those who exchange maps with others too
 

·
Registered
Joined
·
51 Posts
I tried 5 different codes and none worked for rev xtend.
That didn't really matter when it wouldn't communicate for a whole race.
I did buy it used from someone here, it may just be junk.
 

·
Speed Freak
Joined
·
12,730 Posts
Discussion Starter · #7 ·
I tried 5 different codes and none worked for rev xtend.
That didn't really matter when it wouldn't communicate for a whole race.
I did buy it used from someone here, it may just be junk.
The rev extend has always been a hit or miss type deal. Updating the firmware sometimes will clear things up...
 

·
inappropriate
Joined
·
7,728 Posts
okay without me playing around with my pc3 let's just say if I were using vince10r's rev extended enabled map on my pc3 that is not utilizing a ign module then I may have an issue on my hands? How do I check to see if it's enabled?
 

·
Speed Freak
Joined
·
12,730 Posts
Discussion Starter · #12 ·
I can't go play with mine right now to see if this works on a PC3 without an ignition module... but I pulled this from the manual. It might be what you're lookin' for.
if you enable the rev extend with out an ignition module you will have the same issues that I was having, the power commander will have a code and the bike will have some stumbling.... So unless you have the Ign module hooked up I would not enable the rev extend!
 

·
Registered
Joined
·
451 Posts
I tried 5 different codes and none worked for rev xtend.
That didn't really matter when it wouldn't communicate for a whole race.
I did buy it used from someone here, it may just be junk.

You have to know how to set them up to work correctly for rev extend !
I have something on my site as what to do.
 

·
Registered
Joined
·
664 Posts
You have to know how to set them up to work correctly for rev extend !
I have something on my site as what to do.
Looked through a few of your web pages but didn't see what you are referring to. Can you provide a direct link? Thanks.
 

·
Registered
Joined
·
51 Posts
I didn't see it either, I did have mine back on the dyno the other day and as soon as I hooked it back up motor was breaking up real bad, probably send it in to get checked.
 
1 - 16 of 16 Posts
Top