Kawasaki ZX-10R Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi Folks,

I have an '05 model ZX-10R but hate the weirdo LCD tachometer. I'd like to replace that with the instrument cluster from the 2nd gen '06 model bike.

Checking the service manuals shows that the wiring is reasonably similar - the only difference I can see is that the g2 bike has a single wire for oil pressure + FI warning - but I hear rumors that the later model bike has a very different speedo sensor which would impact the speedo reading...:dontknow:

Has anyone done this swapout successfully ? If so could you please let me know exactly what's required ? Detailed instructions with photos and wiring diagrams would be greatly appreciated.:eek:ccasion1

Thanks !!!

Rob
 

·
Registered
Joined
·
2,427 Posts
That change out was explained in 2006 I think it was. You will find that it is not an easy swap. Do a search for it. Good luck

edit: My only contribution to that topic.....was a frickin scan of the 2nd gen pin layout. Now I need to relook that one up. lol
 

·
Registered
Joined
·
87 Posts
I installed a Z1000 Dashboard on my '05 race bike, the basics are full functionally except the fuel gauge. (I don't have it)
Sorry but I don't need turn lights, chronometer or headlight, and I don't connected this, but I think that will work well.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
Done !!!!

Thanks to all for the help.

the overall process was :

1. source new gauge - I used Ebay

2. open gauge, de-solder new cluster's female connector block

3. source Acumen DG8 wiring loom - cut off most of it but retain female connector for 04/05 model wiring harness + tail cables.

4. solder tail cables into the slots vacated by the 06/07 connector. Note wiring is similar but not entirely the same as the older model. Check manuals for details. Or PM me, I have the pinouts

5. cross-connect the cluster's 12v power input to the to the gen1 bike's speed sensor power wire - the gen2 cluster doesn't supply this

6. source & setup Speedo Healer v4 to compensate for the 7.4x difference in speedo sensor pulses between Gen1 & Gen 2 bikes.

7. Enjoy
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
sure but I can't seem to get them to upload to the forum ? it keeps giving me an error message, or timing out or something. Is there a file size limit ?

either way I'm happy to share all the info I have, PM me for more details.

Cheers

Rob
 

·
Registered
Joined
·
1,730 Posts
haha awesome. i don't like my digi tach either. wish it was analog
 

·
Registered
Joined
·
17 Posts
Discussion Starter #15






























HUGE thanks to Bluedevil and JDGUN_13 (who's in a magazine recently by the way) for all their help with this.


###
note a few pictures didn't make it into this post (why???) - but they're all in my album here, numbered "slide 1 to 15" though they seem to show up in reverse order http://zx-10r.net/forum/album.php?albumid=263
###

PM me for more help. I have a spare Acumen harness if anyone wants it.

Cheers

Robert
 

·
Registered
Joined
·
9 Posts
Vary nice thanks a lot
 
1 - 20 of 21 Posts
Top