Kawasaki ZX-10R Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,944 Posts
Discussion Starter #1
Well, I will have to problably east some crow on this! Last night I busted the chain of my 10R. I was running an ERV2 520 chain. It bust at the master link. I did get lucky though. I put a small crack in the tail section, bust the left rear turn signal, bust the front procket cover and chewed up the aluminum rear sprocket.

Needless to say, I will be going back to a 525 chain with new sprockets.
 

·
Registered
Joined
·
620 Posts
damn that sucks man, glad your not to banged up
 

·
Bloo Moderator
Joined
·
23,742 Posts
Did the Master link break a pin or did the front master link plate come off? Just wondering since that a pressed pin. What tool did you use to press the pin? I have an ERV2 and drag race with it no problems so far with 1000s of miles on the chain.

.....and by the way, I am also glad you didnt get injured.:thumbsup:
 

·
Bloo Moderator
Joined
·
23,742 Posts
rocketracermike said:
Thats the second 520 chain to break.
yeah, I was also thinking the same thing but the last one to break was a cheap color green chain(not as strong as an ERV2).......and how many of us are running 520 ERV2 chains:dontknow:
 

·
Registered
Joined
·
1,405 Posts
bluedevil said:
yeah, I was also thinking the same thing but the last one to break was a cheap color green chain(not as strong as an ERV2).......and how many of us are running 520 ERV2 chains:dontknow:
Got one here. Installed it last summer and have just a few hundred miles on it... and I check the masterlink after almost every ride.
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #9
Pics, Yes...But not with the digi cam. The batteries were dead but I will get some new batteries and take some more pics.

Yes, ths chain broke at the masterlink. I was not able to find the masterlink bit I did get the rest of the chain. I haven't checked real close yet, so I cannot say if the pin broke or if the front plate came off. I used my buddies chain press tool and I measured across the front and rear face of the link to make sure it was the same thickness as the other links.

I am not sure if I want to try another 520 or not....Especially since I have a track day on Sept 11th.
 

·
Registered
Joined
·
1,018 Posts
That sucks to hear about your chain breaking. Too bad you don't have pics of the master link to look at. How were you riding when it broke? Were you just cruising around? Stunting? Or just getting on it real hard?
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #11
I got on it pretty good. The front came up before I had it starightened in the lane. I was kinda leaning off the left of the bike to keep it away from the curb. I hit second and the motor just free reved. I though I had smoked the tranny at first.

I have been running hard lately....I don't know if was the power wheelies that done it in or what. I don't wheelie intentionally, but I have been riding the twisties a bit the past few weeks. I have had several occasions where I come out of the corner and the front end is in the air....Maybe too much of that and the chain couldn't take it....Who knows.
 

·
Hillbillie Mod
Joined
·
20,155 Posts
what type of chain maintenace are we talking about here?
 

·
Registered
Joined
·
270 Posts
hillcountry10r said:
what type of chain maintenace are we talking about here?


Like hillcountry10r says, I think chain maintenance has a part to play. I used to lube my DID ERV2 520 chain every 400 miles of riding or whenever I ride through rain and they have never given me any problems.

Proper chain maintenance keeps the X rings lubricated, which in turn serves to lubricate and cool down the chain under hard use.

Keep in mind that these 520 chains are designed to be lighter and stronger then the stock 525 units so if they break, I doubt the stock ones would have faired any better.
 

·
Yankee Racer
Joined
·
14,838 Posts
well chain maintenance or how well the pins were pressed on and with what tools. I know I had a 525 break off at the master because i didnt mushroom the pins enough. Did it right this time and no problems although it is a 525 still. I also had the front up exiting a corner shifting into 3rd when the chain snapped...
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #15
The chain was cleaned every other ride and lubed after every ride. I am starting to think I may not have gotten a good crimp on the pins. The chain press tool was my buddies and I thought at the time it looked a bit worn. I may pick up a new one but I am still going to a 525....
 

·
Yankee Racer
Joined
·
14,838 Posts
mach_man_187 said:
The chain was cleaned every other ride and lubed after every ride. I am starting to think I may not have gotten a good crimp on the pins. The chain press tool was my buddies and I thought at the time it looked a bit worn. I may pick up a new one but I am still going to a 525....
probably a good idea. I thought I did it right to but after i got a little bit better tool and had a buddy who works on bikes watch me and make sure I did it right I knew I did it wrong the time before...
 

·
Registered
Joined
·
735 Posts
Sorry to hear about your damage bro.. Glad your ok.

Hey what track are you going to on Sept 11th?
 

·
Registered
Joined
·
1,360 Posts
zx10ragentblack said:
well chain maintenance or how well the pins were pressed on and with what tools. I know I had a 525 break off at the master because i didnt mushroom the pins enough. Did it right this time and no problems although it is a 525 still. I also had the front up exiting a corner shifting into 3rd when the chain snapped...
I installed a 520 kit on my 954 and so far so good with 5k miles on it. You mentioned mushroom it out. Are you suppose to mushroom it out after using the chain press? Did you use a C-clamp to mushroom the link or what?
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #19
conspiracy said:
I installed a 520 kit on my 954 and so far so good with 5k miles on it. You mentioned mushroom it out. Are you suppose to mushroom it out after using the chain press? Did you use a C-clamp to mushroom the link or what?
No, I used a chain press tool....Not a C-clamp. I know better than that.

Colin....I am going to Grattan on the 11th.
 

·
Registered
Joined
·
765 Posts
i think that steering dampner is crap does anyone else agree? with i all the way tight it still wobbles and what makes it worst it feels like its trying to work is ohlins normally better then that or did they kawi some bullshit ?
 
1 - 20 of 25 Posts
Top