Kawasaki ZX-10R Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi My first post so please be gentle!!
I've searched for ages on here for the answers to my questions but with no success, so hopefully someone will be able to help me....
05' ZX10 track bike:
My FI light flashes at approx 5s intervals when the ignition is off. The key is lockwired in place.

The F1 light is on all the time with the engine running, it has no servo and no 'eliminator' Are these 'faults' normal?

My previous trackbike was an 03' R1 and i haven't even ridden the 10' yet as it's snowing currently in the UK. I'll post some pictures on here when i get a chance.
Many thanks
Rob.
 

·
Registered
Joined
·
1,508 Posts
nope It flashes at 5s intervals after turning off for some hours... not sure how long, but this is the immobiliser warning. Should be off when running
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Thanks for your speedy response

Just to clarify what the bike is doing:

Ignition off ----(but key in barrel) FI light flashing.
Engine running----FI light on.

If this is not normal, what would be the cause and does it matter if the FI light does what is does?

Thanks again.
 

·
Registered
Joined
·
3,561 Posts
it matters when the FI light is on. They serve to indicate a fault with your fuel injection system, the exhaust servo is regarded as part of that system. Thus light will flash. You should get hold of a manual and learn to read the codes.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Thanks
All i really want to know will the light cause it to slow down or blow up?!
Not bothered if a lights on!!
 
1 - 6 of 6 Posts
Top