Kawasaki ZX-10R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Just installed the OEM Euro front turn indicators from ZPower in England and purchased and installed OEM American bulbs. Only problem, lights now flash very fast. What has to be done to get the flash rate back to normal.

realestateguy
 

·
Registered
Joined
·
2,869 Posts
If you do a search this has been discussed but.....three thing that you can do....

1. removed the bulb and put the stock bulb in the euro fixtures
2. put a resistor in line
3. change the blinker relay to an EL12...this also enables you to change the rear blinkers also and keep the correct speed

hope this helps
[smilie=3:
mavrik
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
Thanks Mavric. I ran a search and found this:

All you need to go do is going down to an autoparts store. Buy a 2 prong non load dependant flasher relay. Take out your stock flasher relay (under the seat/plastic thingy, and wire in the new one. I had to do this when I put my undertail on with led turnsignals. Now it flashes normal.

Autozone and pick up a heavy duty flasher relay.....I did this mod and it works great....did it on my R1 also....the part number to the flasher relax is EL12

Or you can buy a resistor from Radio Shack for about $1 and wire it in the circuit. This increases the resistance and returns the blink rate to normal.

I did replace the Euro bulbs with US spec ones but that didn't work. I'll try the relay first, then the resistor. Do you know the specs on the resistor?

realestateguy
 
1 - 3 of 3 Posts
Top