Kawasaki ZX-10R Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,069 Posts
Discussion Starter #1 (Edited)
Does somebody have a tip or easiest way to re-install the inner black liner under the headlight? I've been trying to install these dang CA front signals for an hour and I can't get the dang inner liner back on. I don't know which side to line up first so if anybody has done this install please give me some tips...otherwise I'm gonna trailer this sucker over to my shop. :BangHead: :BangHead:

P.S. I wish there was a "how to install Flush signals" with pics on this site but there isn't yet. I would attempt to do one now, but I loaned my camera to a friend a couple weeks ago :sad:
 

·
Registered
Joined
·
928 Posts
i dunno mang, i didnt remove those pieces to install mine, just remvoed the 3 screws holdin them on and poped em out. :dontknow:

do u have ur lowers removed and the mids?
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #3
projekZERO said:
i dunno mang, i didnt remove those pieces to install mine, just remvoed the 3 screws holdin them on and poped em out. :dontknow:

do u have ur lowers removed and the mids?
Well, Good news is I finally got the dang liner back on, I just needed someone to hold it while I screwed the back part on cuz it kept movin'. Yes, I removed the mids, but not the lowers. I guess I didn't even need to remove the mids huh? Well, at least I know now for the other side :lol:. Thanks Zero :wink:
 

·
Registered
Joined
·
1,595 Posts
I took off the mids and took out the three screws on the inner to take off my signals to the euros.

Also if you didn't see it in another post, pre screw in those back screws before installing to make it easier..
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #6 (Edited)
What is This?

Ok, guys when I took one of the allen head screws off of the inner panel, this thing fell out. i'm not sure what it is and I couldn't figure out where it went so I reinstalled everything and left it off. Can somebody tell me what this is and how important it is? Nothing like this fell off when I did the other side. It looks like it may have been extra padding between the panel and mids? :dontknow:
 

Attachments

·
Still here
Joined
·
9,059 Posts
You now have the piece used in this mod:
http://www.zx-10r.net/forum/showthread.php?t=15355

by project zero
"Also I found a bendable tab that wasnt being used when I installed my euros. It was completely straight and not holding anything so when I installed the euro's I removed it but held onto it. Well it came in handy cause in the next pic you can see how i used it to hold the harness out of the way. Looks factory!"
 

·
Registered
Joined
·
1,113 Posts
That thing is supposed to hold your wires out of the way of something. I dunno what but I remember keeping all of my wires on one side it for some reason. It's been awhile since I had it apart, sorry.
 

·
Registered
Joined
·
5,228 Posts
speedfreak said:
That thing is supposed to hold your wires out of the way of something. I dunno what but I remember keeping all of my wires on one side it for some reason. It's been awhile since I had it apart, sorry.
:+1:
 

·
Registered
Joined
·
928 Posts
i wish i took a picture of mine when i removed it, that tab wasnt holding SHYT and where its located i dont see what it would be holding.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #12
projekZERO said:
i wish i took a picture of mine when i removed it, that tab wasnt holding SHYT and where its located i dont see what it would be holding.
Cool, I didn't think that tab was anything to worry about. I went for a little ride today around Cook's Corner and everything seemed to work fine.

On another note, I noticed my new CA integrated tail and front signals don't blink at a fast rate like some other units. Anybody else notice this? I'm wondering why they even gave me the stupid resistors...I DON'T NEED THEM :lol:
 

·
Registered
Joined
·
1,595 Posts
I got me one of these to get the steady blink

 

·
Registered
Joined
·
1,276 Posts
IcePick..if you need help with lil stuff. Let me know. I did my Euro install @ my shop...pretty easy. I just picked up a front and rear OEM Euro set off ebay for $60...put the rears on and now I'm going to swap out my LP fronts for the factory.

the Electronic Flasher that CA sells works good too.

Ice, yours doesnt flash fast??? do all your turn indicators work?
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #15 (Edited)
Fixer said:
IcePick..if you need help with lil stuff. Let me know. I did my Euro install @ my shop...pretty easy. I just picked up a front and rear OEM Euro set off ebay for $60...put the rears on and now I'm going to swap out my LP fronts for the factory.

the Electronic Flasher that CA sells works good too.

Ice, yours doesnt flash fast??? do all your turn indicators work?
Thanks Fixer but I installed the tail and blinkers just fine (had a few problems at first with one side but the rest was a piece of cake). Yeah, all my signals work fine...I was just wondering why my tail and front signals flashed at the normal slow "stock" rate without me installing resistors or the electronic flasher :dontknow:

Has anyone noticed that the CA euro signals don't fit 100% completely flush with the body panels? Mine looks cool, but if you get up close you can see a tiny gap (less than a quarter inch) where the CA unit and body panel are supposed to meet.

BTW: Fixer, Where's your shop in So. Cal?
 

·
Registered
Joined
·
1,113 Posts
Mine has the tiny gap also. I believe that the l.e.d.s are the only one that will make you signals blink fast. They don't have the current draw that bulbs do so your relay thinks you have a bulb out and they will flash fast (just like in a car). If you install leds you can install an EL-12 (i believe) flasher relay from any napa or oreillys auto to return blinkers to normal speed.
 

·
Registered
Joined
·
1,276 Posts
Its an cage dealer..in cerritos.

I have the Lockhart (sp) Phillips euros on mine..and they dont seem to fit right in the corner....but I putting on the OEM euros today and I'll see what the difference is.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #18 (Edited)
Fixer said:
Its an cage dealer..in cerritos.

I have the Lockhart (sp) Phillips euros on mine..and they dont seem to fit right in the corner....but I putting on the OEM euros today and I'll see what the difference is.
Cool, let me know if there's a tiny gap too. I like the look of my smoke lenses, but I think Clear Alternatives could've done a better job matchin' the fit with OEM if those do indeed fit better.
 

·
Registered
Joined
·
1,595 Posts
I think the main problem is how to align those stupid screws to angle in right to get the right fit...without it pre screwed at the proper angle it is always gonna be alittle off
 
1 - 19 of 19 Posts
Top