Kawasaki ZX-10R Forum banner
1 - 5 of 5 Posts

·
Registered
2016 Kawasaki ZX-10R KRT ABS Edition
Joined
·
683 Posts
Discussion Starter · #1 ·
Rebuilding bike and getting this code: P2227, barometric pressure circuit range/performance. Help? Bike is in limp mode. I keep erasing the code, comes back instantly.
 

·
Registered
Joined
·
128 Posts
Bad sensor or connection
 
  • Like
Reactions: SkyDork

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,735 Posts
Bad sensor or connection

This. Just because the code is cleared doesn't mean the fault is cleared. The sensor is inop or the ECU can't see the sensor for some reason.
 

·
Registered
2016 Kawasaki ZX-10R KRT ABS Edition
Joined
·
683 Posts
Discussion Starter · #4 ·
I think I figured it out. In the process or removing some emissions from the bike you have to remove 5 throttle body hoses. 1 in the front and 4 in the rear. I wasn't understanding the directions completely though because in the picture the hoses didn't match up accordingly... the front tube going to the body appeared to be on the right side as opposed to the left on paper. I went ahead and removed the hose, that was on the right, which was attached to a sensor. Little did I know, after some thorough inspection, that there was a hose on the frt-left side of the throttle body but it had been previously removed! So, I was looking for a hose that had already been removed, and in the process ended up removing another one that mistakenly looked close to the description.
 

·
Registered
Joined
·
128 Posts
KOOL
My manual probably tells how to test the sensor with a volt meter
 
1 - 5 of 5 Posts
Top