Kawasaki ZX-10R Forum banner

1 - 20 of 45 Posts

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #1
Im at WORK (again)... and my tank is leaking.
Fuel is LITERALLY dripping between the two parts i circled in the pic.
Should there be a rubber seal (o-ring) in between because I didnt find any.

I dont wanna ride it with a fuel leak BUT i also dont wanna leave it at work.
help pls.. thanks

-Lucky
 

Attachments

·
Registered
Joined
·
162 Posts
I don't know how far you have to ride to get home, but for a quick fix tape it up and wrap it with some rags. Maybe that will be enough to get it home and asses the problem farther. Just an idea. Good luck though.
 

·
Bloo Moderator
Joined
·
23,742 Posts

·
Bloo Moderator
Joined
·
23,742 Posts
I don't know how far you have to ride to get home, but for a quick fix tape it up and wrap it with some rags. Maybe that will be enough to get it home and asses the problem farther. Just an idea. Good luck though.
AT 40psi of pressure :headshake:..no not a good Idea :headshake: fix it first or get a Tow Truck.

bloo
 

·
Registered
Joined
·
474 Posts
If you can pull the line off without popping out the lock tab...you didn't get it on all the way.:+1:eek:n the fix it or go get a pick up or trailer.Don't want to be a fireball going down the street!
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #8
hehehe.. i risked it... im at home right now...
but now the bike dies like its out of fuel...
it was running.. i rode it home... and now it starts, and then dies right away like out of gas...

what to do?
what to do?
 

·
Bloo Moderator
Joined
·
23,742 Posts
hehehe.. i risked it... im at home right now...
but now the bike dies like its out of fuel...
it was running.. i rode it home... and now it starts, and then dies right away like out of gas...

what to do?
what to do?

Geez, it's like talking to your Kids....check out Daves post right above yours for starters. :idea::wink:
 

·
Bloo Moderator
Joined
·
23,742 Posts
we're family here :thumbsup:
Well then, did you listen to your MAMA and check it out? probably NOT :spank::spankbw::spankbw:


:lol:
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #12
...the hose (fuel line) is all the way in... i pushed it in as much as i can... then cliked the lock back in... still not working... it DOES start and runs... but i had to yank the throttle..

also... i hooked it up to my laptop... power commander says the throttle is 100%... all the time...
 

·
Bloo Moderator
Joined
·
23,742 Posts
...the hose (fuel line) is all the way in... i pushed it in as much as i can... then cliked the lock back in... still not working... it DOES start and runs... but i had to yank the throttle..

also... i hooked it up to my laptop... power commander says the throttle is 100%... all the time...
What's the Power Commander have to do with it leaking in the place you described? Ok, I will tell you.......NOthing...Is it leaking there or not?:dontknow:

100% sounds like flooding so maybe that's it but doesn't explain the leak where you described it. :dontknow:
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #14
...ok here's the whole story:

I rode it to work...
after a whole 8 hours, when im bout to go home, i noticed a lot of fluid underneath the bike... so... i smelled it and its 100% gas... so i looked at some of the openings, and voila, near the pump... i saw fuel literally dripping.. so i unscrewed the tank so i can see more... i popped up the tank (not really removing the whole thing, just enough so i can see better) and i found out that the leak was where the fuel line is connected to the tank...

and then i drove it home.. after reading this thread, i tried the advises... i plugged and pushed in the fuel line as much as i can then quickly hit the lock so it stays in place.

THERE's NO MORE LEAK NOW.

but the bike starts and then dies.
to keep it running, i had to yank the throttle really fast...
it was like a cat and mouse chase.. im chasing it through the throttle to keep it from dying..

if i leave the throttle, it just dies asap.
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #15
about the power commander, i just hooked it to see if maybe thats the problem why its dying... there are no more leaks now.. but when i hook the PCIII, on the throttle window, it just say 100% even though i play with the throttle.
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #16
...i dont know if this is related...
but the bike is effing hot! i ve never had it this hot...
even the frame is hot, i can barely put my hands on it for a few minutes.
 

·
Registered
Joined
·
1,279 Posts
This is a weird one indeed!!! Well for starters have you had the tank completely off and on the floor for any extended period of time? If you have its possible to bend the spout coming from the fuel pump if to much pressure is put on the right side of the tank. That may be where the leak is coming from and pooling where the fuel line connector meets. If that's not the case then most likely the line wasn't 100% on. But now since you say it stopped leaking after you pushed and pulled and fanagled with it problem solved I guess. Now to the dying issue. Rule out the PCIII by unplugging it for now. If the problem goes away then the PCIII is the culprit. If problem precist TPS sensor could be out of wack. If PCIII software is reading 100% throttle all the time then TPS might have issues. I'd start at those two points if that doesn't help let me know and we can go further.
 

·
Registered
Joined
·
1,279 Posts
Oh and I doubt the heat has anything to do with it unless it melted something.
 

·
Registered
Joined
·
724 Posts
Wow...issues. Well I have an '06 so I can only give you based on general moto knowledge. Unplug the PC and see if your issues go away....if it doesn't then start simple, heat may mean it's running way too lean and your throttle issue sounds like it. You need to check out your fuel pump and tank to see WTF is going on. Just because the leak is fixed doesn't mean your problem is gone. Use the manual...see if there's a way to check your fuel pump and TPS, sounds like your have some malfunctioning parts. How many miles you got on that bike ? Have you done any work on it lately ?
 

·
FEELING LUCKY, PUNK ?
Joined
·
5,739 Posts
Discussion Starter #20
update:

so i yank up the idle to about 2000, voila the bike aint dying...

well... just when i thought i fixed it.. i took it for a run... after 1 block (about 100 feet) the bike starts to die again so i had my right wrist twisting the throttle twice every second..

it was really weird because at one point, i had the throttle at max... max as in i cant twist it anymore... but its really not what the bike is doing.. so i held it on max throttle... and the biked sounded like it tries more than 5 times just to get to wot...

so im thinking its the throttle cable...
but wait....

when i had the leak, the bike was running fine... runs perfect, normal, everything was ok... except it had a leak..

when i fixed the leak, the bike is suddenly dying.. im like wtf is going on ?

i dont think theres a problem on the pump or the line... because if you really think about it, it was running 100% fine even with a leak... and now its not because theres no leak anymore? so i rule out the fuel tank, fuel line, etc.... the bike was running 100% fine with a leak, but not anymore without the leak... so i ruled out the PCIII too...

maybe the bike is just flooded?
perhaps.

but if its flooded, i dont think it will run at all..
the bike runs, but i had to keep up on twisting the throttle.

im running out of idea. i checked everything... battery is 100% charged... tank is almost full.
 
1 - 20 of 45 Posts
Top