Kawasaki ZX-10R Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
:welcome:

Dear friends, good afternoon.

I recently had problems with my zx10r 2012 not-abs, broke the ECU, my bike and BR, not US, soon there is the immobilizer is the oxygen sensor, my original ECU was 21175-0766 - went on ebay I bought a 21175- 0764 but the American ECU does not have immobilizer, which does not inflame in the American ecu, but when putting the bike in place, it does not work, it has no error code, it does not diagnose as soon as it starts the ignition, it does not listen to a gas pump, the ECU does not send the negative pulse to the relay box for the gas pump, comparing the 2 wiring diagrams of the ECU-ECU is ECU-US I saw that the GY wire leaving the US ignition does not exist in BR , I made the processing of by connecting the ignition wire 12v to the ECU-US pin 68 even so nothing, does not initial diagnosis nor listen to the gasoline pump. follows video link of how it is.

zx10r Not start.

Help me Pls.
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,701 Posts
:welcome:

Unfortunately you have to source an immobilizer equipped ECU. There's no way to bypass it because that would defeat the purpose of having an immobilizer. Not really sure how you "break an ECU", but you need to to get one equipped with that out of Europe or South America. Not a US one.

Aside from that, you could potentially change the entire bike over to a US model. That would require a US wiring harness and ignition switch, and you have to remove your immobilizer from the bike.

Good luck!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
:welcome:

Unfortunately you have to source an immobilizer equipped ECU. There's no way to bypass it because that would defeat the purpose of having an immobilizer. Not really sure how you "break an ECU", but you need to to get one equipped with that out of Europe or South America. Not a US one.

Aside from that, you could potentially change the entire bike over to a US model. That would require a US wiring harness and ignition switch, and you have to remove your immobilizer from the bike.

Good luck!
No friend, the immobilizer is on the top of the ignition is 2 wire to the antenna that goes to the module amplifier (immobilizer) has 4 more wires, 2 are power, 2 are ecu. these 2 that go to ECU, the American ecu this option and deactivated soon the wiring of the immobilizer does not influence the rest of the wires of the motorcycle because it is straight to the ecu, so if it were only that would work, but different from the American model to the Brazilian model. different 1 ignition wire "BL wire" going on pin 68 of the ECU powered by the 12v of the ignition, what I wanted to know if someone from the forum already tried or better someone from the forum could make available a photo of the 2 ECU connectors, model American. so I can make the comparison and thus heal my problem, I hope someone helps.
 

·
Registered
Joined
·
2 Posts
hi ,

i am facing similar issues. converting japan spec to usa spec.
list of items i change - meter, ecu, wiring harness, ignition key. but the bike wont start.

meter show no error, no check engine light, feul pump runnning, ohlin damper initialize properly.

what should i do next, please advise.

wasap.my/60129099381
 
1 - 4 of 4 Posts
Top