Kawasaki ZX-10R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
I ordered a QEM for my zx10r from the US but I got a QEM for zx6r 09.
Its labeled QEM 2b kaw zx6r 09, it should say QEM 6 zx10r 09.

Does anyone know if I can use this on my zx10r?
Is it the same connectors?
Is it just the length of the cables?
Is it the same hardware?

I really dont want to send it back from Sweden and wait for a new one!

Any help apreciated!
 

·
Registered
Joined
·
881 Posts
The thing is, there is no part numbers except the QEM-2B for the 6r and the QEM-6 for the 10r :dontknow:

Did you tried to plug it on the upper injectors? Sorry but I only have experience with it on the Suzuki's,but if it plugs on your upper injectors and they work fine and you get no FI light etc,then you should be fine...

Just check that it cuts fuel when it gets the signal from the sensor...
 

·
Registered
Joined
·
138 Posts
Discussion Starter #5
Did you tried to plug it on the upper injectors? Sorry but I only have experience with it on the Suzuki's,but if it plugs on your upper injectors and they work fine and you get no FI light etc,then you should be fine...

Just check that it cuts fuel when it gets the signal from the sensor...
I have just finished to install it. It fits fine ,the only difference i guess is the length of the cable harness. The pc and qem lights up and no fi light and the engine runs!:thumbsup:

To bad the weather is to cold to take a spinn!

Thanks for the input!
 

·
Registered
Joined
·
138 Posts
Discussion Starter #7
I put the bike on a rear stand and it cuts fuel as it should thru the gears!

So all is good so far! :wav:
 

·
Registered
Joined
·
881 Posts
I put the bike on a rear stand and it cuts fuel as it should thru the gears!

So all is good so far! :wav:


OK,so the thing is to adjust the kill time and threshold through the PC-V,and then as the bike sits on the rear stand try to do some clutchless upshifts... :thumbsup:
 
1 - 8 of 8 Posts
Top