Kawasaki ZX-10R Forum banner

41 - 60 of 68 Posts

·
Registered
Joined
·
388 Posts
Did you have the squealing too?

Damn bike kept running like dog crap. I updated the firmware and still had no change. I ended up removing the PC5 to try it without it for the second time. It did have the "stock/zero map" uploaded so I assumed the PC wasn't doing anything except powering on. After removing it, the bike has been running like a beast for the past few weeks. I haven't had time to get a hold of Dynojet about the unit, but will be doing so this week.
No squealing.
 

·
Registered
Joined
·
388 Posts
Just got a package back from dynojet. They replaced my old pcv.
will be installing this wknd
 

·
Registered
Joined
·
33 Posts
Sent an email on this subject to Dynojet Technical Dept today and got this reply.

"The problem highlighted in this thread is a Firmware problem which came to light a few years back, the firmware update to the latest version (1.0.10.6) fixed this. I have not heard of this problem or seen it for a long time."
 

·
Registered
Joined
·
2,805 Posts
Discussion Starter #44
Sent an email on this subject to Dynojet Technical Dept today and got this reply.

"The problem highlighted in this thread is a Firmware problem which came to light a few years back, the firmware update to the latest version (1.0.10.6) fixed this. I have not heard of this problem or seen it for a long time."
Yeah the issue should've been fixed for good. This thread is just up at the top of the forums in case someone gets an old PCV with old firmware on it. Just to help mitigate additional topics on the subject since it has been fixed by Dynojet

:eek:ccasion1
 

·
Registered
Joined
·
116 Posts
Had this issue too. Tuner told me he updated it to V1.10.8.6.

My question is ... I can't even find this version on the official Power Commander website. Was he bluffing or do official tuners receive different firmware versions from those posted on the website?

Bike is running fine (so far). I live about 100 miles from the nearest tuner, so just wanted to make sure.

Also, if I have to update the firmware in the future, do I need to re-tune it, i.e. will my map disappear?

Thanks.
 

·
Registered
Joined
·
2,805 Posts
Discussion Starter #47
Had this issue too. Tuner told me he updated it to V1.10.8.6.

My question is ... I can't even find this version on the official Power Commander website. Was he bluffing or do official tuners receive different firmware versions from those posted on the website?

Bike is running fine (so far). I live about 100 miles from the nearest tuner, so just wanted to make sure.

Also, if I have to update the firmware in the future, do I need to re-tune it, i.e. will my map disappear?

Thanks.
I looked and couldn't find any reference to that version anywhere in my usual places.

So I can't speak if he is telling the truth or not. One way to find out would be to plug into your Power Commander with software and mini USB cable. That will tell you exactly what FW version is on there.

If you update the firmware, that will not change your map values.
 

·
Registered
Joined
·
388 Posts
I called dynojet and explained what was going on..
i sent it in shipping paid by dynojet..
got a new one..
 

·
Registered
Joined
·
116 Posts
I looked and couldn't find any reference to that version anywhere in my usual places.



So I can't speak if he is telling the truth or not. One way to find out would be to plug into your Power Commander with software and mini USB cable. That will tell you exactly what FW version is on there.



If you update the firmware, that will not change your map values.

Hi Archer,

I managed to obtain the firmware from the local tuner. I've created a link for it which you can download:

https://www.dropbox.com/s/dypggl42rm6mj3k/firmware.zip?dl=0

Would you mind checking for me whether this is indeed firmware 1.10.8.6 as mentioned.

I'm getting paranoid riding the bike without being entirely confident whether it is dropping a cylinder. With the Racefit exhaust it's really hard to tell the difference as it's so god damn loud. Are there any long term effects on the engine if I keep running with 3 cylinders?

Thanks.
 

·
Registered
Joined
·
2,805 Posts
Discussion Starter #50
Would you mind checking for me whether this is indeed firmware 1.10.8.6 as mentioned.
I don't have a Power Commander any longer so I can't check the version. It also doesn't let you select the "Update Firmware" option without having a Power Commander hooked up and connected through the software. So unfortunately I can't.

It's not hard to do though, so if you have a laptop and a USB cable (mini USB), you can do it within a few minutes.

* Download the Dynojet software to your laptop: http://www.powercommander.com/downloads/Support-Released/PCV/Software/Install_Power_Commander_5_v1.0.6.4.zip

* Install the software

* Connect the USB cable to your laptop

* Connect the other end of the USB cable to your Power Commander

* Give it the needed time to install the drivers for the Power Commander

* Open up the Power Commander software

* Look at the bottom status bar and make sure it says the Power Commander is connected

* Inside the Power Commander software click "Power Commander Tools" --> Update firmware.

* This will open up a new window and will show you the version currently loaded.
 

·
Registered
Joined
·
116 Posts
Turns out even with the updated firmware it wasn't working properly, exhaust temps in cylinder 4 was much cooler than cylinder 1 (using the water squirt test), hence I'm getting rid of the Power Commander. It's not worth the time to ride up and down to the dealer.

What's a good alternative? Have heard good things about the Rapid Racing box and the Bazzaz?

Thoughts?
 

·
Registered
Joined
·
2,805 Posts
Discussion Starter #52
What's a good alternative? Have heard good things about the Rapid Racing box and the Bazzaz?

Thoughts?
Bazzaz? Unless your ECU is flashed you're not getting the most out of the bike you can be.

Rapidbike? Does a little more than a Bazzaz, but its just another piggyback add on following Dynojets business model; pay $x to unlock y features. Ends up being over $1000 on the end and your bike is now filled with extra wiring and add on modules.

My opinion go with Woolich. You can go with the Mitsu USB interface for the price of a Power Commander and tune A LOT more stuff directly through the ECU. If you want autotuning and data logging you can go with their Log Box product for a little more. Finally if you want to add their new launch control and quickshifter you can pay a little extra to have that as well. Pretty much with each product release, Woolich is getting better and better.

If you want pricing on their products, shoot me a PM I can shoot you a few different options at different price points and get you a discount on a package for you if you order through me. I'll also help you set everything up over the phone or Skype/Google Hangouts.
 

·
Registered
Joined
·
116 Posts
I guess I forgot to mention my current setup:

- US spec bike
- Woolich flashed ECU (all restrictions removed)
- Power Commander (now removed)
- Translogic quickshifter
- Akrapovic Evolution header
- Racefit Black edition slip-on & y-adapter
- stock motor (18000 miles)

Power = 180 whp (with Power Commander)
Power = 177 whp (without Power Commander)

I guess I'm just looking for a little extra to push it to 185 whp (or more). The imported Euro spec bikes are hitting 203 whp with Bazzazz and full exhaust!!!!
 

·
Registered
Joined
·
36 Posts
I have the latest firmware and still had the problem so that can't be the fix for everycase. I stripped it down hust to have a look and found corrosion on the terminsls where the wires join the circuit board. I clean it up snd resoldered them and so far after two rides no misfire. The circuit board is sealed in grey silcone so it must of had moisture on it before the silicone was applied.
 

·
Registered
Joined
·
36 Posts
Also my pcv was going in the bin so i did not care if i damaged it. I will post again after a few more rides.
 

·
Registered
Joined
·
791 Posts
Figured I'd throw this out there to see if anyone can comment.

My bike appears to be dropping a cylinder under 5k-6k rpms and obviously seems low on power. Anything above that mark, and to the red line, it's running just fine. As the bike runs more and more, the problem recedes down below 3k rpm mark. The puzzling part is that my bike is not running a Bazzaz or PCV box. It has the Archer flash and that's it. I have been told different things, such as bad coil or even problems with valves. I am pretty puzzled at the moment and wanted to see what you guys think before I start pulling things apart. Thanks!
 
41 - 60 of 68 Posts
Top