Kawasaki ZX-10R Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey i just bought a brand new 2011 zx10 it was the last year model the dealer had wel they said the clutch was slipping a little since its sat on the showroom for a while and was going to have to replace it for me... its gonna be over a week til they get the part shipped blah blah blah my Q is the 2012 clutch assembly the same for 2011 i looked up a ton of clutch assembly info and part numbers but just didnt know for sure before i walk in and tell them to take it off a 2012 and slap it in mine so i can finally drive it home. any help would be great thnx
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
ohh btw all the part numbers for the clutch assembly match from oem part stores... just didnt know for sure if they correct...
 

·
REPOST Enforcement Mod
Joined
·
13,543 Posts
If the part numbers are the same, there's no difference. They are the same assembly.

Good luck getting them to swap parts from the new one to yours. Doubt they'll do that.
 

·
Registered
Joined
·
356 Posts
Hey i just bought a brand new 2011 zx10 it was the last year model the dealer had wel they said the clutch was slipping a little since its sat on the showroom for a while and was going to have to replace it for me... its gonna be over a week til they get the part shipped blah blah blah my Q is the 2012 clutch assembly the same for 2011 i looked up a ton of clutch assembly info and part numbers but just didnt know for sure before i walk in and tell them to take it off a 2012 and slap it in mine so i can finally drive it home. any help would be great thnx


Let me get this straight. The dealer told you the clutch was slipping Because it was sitting on the showroom for a while....? This was a NEW BIKE?
Something's fishy here! To my knowledge a clutch doesn't start slipping from just sitting on the showroom....intake the whole bike back to the dealer and demand they fix it you will call Kawasaki to complain! That is really BS..
 

·
Gen2 Ripper
Joined
·
4,867 Posts
I would NOT buy that bike man. That is likely a demo bike or something and somebody burned the clutch up. Clucthes do not slip from sitting.
My bike was in a crate for over a year when I bought it new. I rode it home and clutch is fine 12k miles later. Same for nearly everybody on this site as the build dates are 6 months to just over a year old before we even buy the bikes.
 

·
Registered
Joined
·
393 Posts
:+2: My 09 sat on the showroom floor 2 years before I bought it, and no clutch problems. Even had it at the drag track and race track. Only thing i can think of is when the dealer first got it they put oil in it and used synthetic and then it sat for a year and 6 months. Maybe the syn oil is cause the clutch to slip a little ?
 

·
Is still Slo
Joined
·
1,538 Posts
This probably is not a local dealership, but which one is it? Just to share with the rest of us..... sounds just like others had already mentioned, clutch glazed/damaged from previous test rides.
 

·
BigCat for Prez!
Joined
·
7,229 Posts
I know the dealer around here would take the new bikes and hot rod them at the track then swap the tires and cluster and sell it as a new bike. They also got busted for money laundering and fixing cash sales to under 10k so they wouldnt have to report it
 

·
Registered
Joined
·
1,204 Posts
Bike have any miles on it when it was delivered to you? Doubt a dealer would switch it to synthetic "just because". They don't want to spend any more money on inventory than they have to. Ever thought maybe it just needs to be adjusted?
 

·
Registered
Joined
·
617 Posts
I just bought mine 3wks ago and got it home for about a week its an 2011 so same as yours, dont have any problems with it. Weird shit going on with your bike, i hope it all gets sorted out for ya !!
 

·
Registered
Joined
·
1,231 Posts
Just from my own personal experience with the 2011, the stock clutch is not great. I am putting new springs in this week.
 
1 - 11 of 11 Posts
Top