Kawasaki ZX-10R Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1 (Edited)
Clutch pressure rod problem, how frequent?

I am wondering if many people had the following problem. The tip of the clutch rod worn out. I was thinking my clutch was going bad because I was not able to launch properly at the drag strip but after reading a thread from "fordfasterr" here I realise that it could be the same problem show in the picture and it fact it was exactly that.

The image was taking from "fordfasterr" but it's exactly the same thing that happen to me with less material remove probably because of the low mileage of my bike. Look at the tip of the center rod, it's all worn out.

My bike is a 2005 and only have 10 000 KM (6,215 miles).


Who had or heard of this problem and witch bike year of zx10r it happens?

I know of 3 person now including myself with the same problem and my worry is that all are on 05 year and I am a bit scare that it may be related on another bad parts like the clutch cover dimension or other related part on the 05 model and if it is the case the problem may come back later.
 

Attachments

·
Registered
Joined
·
2,261 Posts
It happened to me as well. I bought two of them " only after buying a whole new clutch assembly" so that I would have a back up. The berrings wear out as well so replace those. It's a good insurance policy to have a few spares just in case. Good luck.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
It happened to me as well. I bought two of them " only after buying a whole new clutch assembly" so that I would have a back up. The berrings wear out as well so replace those. It's a good insurance policy to have a few spares just in case. Good luck.
What is your mileage and how many time you had to replace those parts since you have your 2004 ?

For the parts you mean I should change the rod, the lever that pull the rod +
the ball bearing.


Thank you for your input!
 

·
Registered
Joined
·
270 Posts
Me too. I had that problem. Replaced it twice already and now i always have one spare on standby. :)

A tell tale sign of your rod wearing out: the distance needed to released the clutch lever will become shorter.. Adjusting the clutch will help somewhat but then the problem will just come back again as your rod wears even more...
 

·
Bloo Moderator
Joined
·
23,742 Posts
really never heard of a major problem on this site....I have to think there is another reason for this happening for you guys....replaced mine a few months ago with 18k and yes I do drag racing not a scratch on the pin or the pulling arm on the clutch cover :dontknow:
 

·
Registered
Joined
·
664 Posts
I got advice from a fellow ZX10R-powered race car owner that they wear out and that it's a must have spare to have handy at the track.
 

·
Bloo Moderator
Joined
·
23,742 Posts
really never heard of a major problem on this site....I have to think there is another reason for this happening for you guys....replaced mine a few months ago with 18k and yes I do drag racing not a scratch on the pin or the pulling arm on the clutch cover :dontknow:
.

after reading my own post I see I wasn't clear...I replaced my clutch and noticed there was NO damage or wear on the PIN....sorry but had to make it clear.

bloo
 

·
Registered
Joined
·
819 Posts
Been there done that, the thing that sucks is if you put some serious springs in there to hold power, the end will actually just break right off, hahahahah:rolleyes:. I am in the process of making a new pin out of better material.
 

·
Registered
Joined
·
664 Posts
Been there done that, the thing that sucks is if you put some serious springs in there to hold power, the end will actually just break right off, hahahahah:rolleyes:. I am in the process of making a new pin out of better material.
Hmm. I wonder if you should make a batch? :).
 

·
Registered
Joined
·
116 Posts
Discussion Starter #10 (Edited)
For those who already answer to this thread and for the other that may do it later,
what motor year and how much mileage before you had to change those parts?
I hope it's more than me at only around 6,000 miles!

Also "redline659" I let us know about that custom replacement pin please.
 

·
Registered
Joined
·
819 Posts
Will do, I have hit quite a few roadbumps with mine,,, clutch basket rivet snapping off trashing motor #1, basket pin end snapping off,,, pinching ring lands, spinning bearings,, hahahah,,,, The rods are still good though:thumbsup:.... Mine gave up at 600 miles heheheheh,,,, Heads up on the 04-05 valve spring retainers, they are cast aluminum,,,,,, JUNK,,,,,
 

·
Registered
Joined
·
116 Posts
Discussion Starter #12
Only 4-5 persons total who had this problem in the past???.
We must be very unlucky !
 

·
Registered
Joined
·
664 Posts
I tried to be liberal with anti seize when I assembled mine, but I'm crossing my fingers it wont break off. I have stiffer clutch springs. I'm an interested buyer if new and improved parts are available.
 

·
Registered
Joined
·
2,261 Posts
What is your mileage and how many time you had to replace those parts since you have your 2004 ?

For the parts you mean I should change the rod, the lever that pull the rod +
the ball bearing.


Thank you for your input!
I had to replace it twice only because the berrings were bad the first time and the new rod got chewed up because of that. After those were replaced than it was all good. :eek:ccasion1
 

·
Registered
Joined
·
116 Posts
Discussion Starter #18
I had to replace it twice only because the berrings were bad the first time and the new rod got chewed up because of that. After those were replaced than it was all good. :eek:ccasion1
Good to know. I will certainly change the bearing at the same time.
Thank you!
 

·
Registered
Joined
·
2,261 Posts
As for mileage I don't know off the top of my head from when it happened. I drag race it and so I'm pretty hard on clutch parts. I also have stiffer springs in but only three not 5 cause I was told that that would give me the desired outcome that I was looking for at the time. It works well.
 

·
Registered
Joined
·
819 Posts
We were trying to hold in 260 hp with the stock setup so we had in HD springs and shims:thumbsup:hahahah and it was still eating clutches but it snapped off along with some other things:lol:
 
1 - 20 of 23 Posts
Top