Kawasaki ZX-10R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3,766 Posts
Discussion Starter #1
I recently change my clutch and now it want engage, disengage properly. My previous clutch was a dragpak but just switch to oem. I replaced all fibers, steels, judder plate and tried adjusting the clutch cable on both ends with no luck. I noticed today with it on rear stand, the clutch lever pull in tire still moves. I thought with lever in tire shouldnt move only with lever out?? I dont wanna burn out my clutch and feel like i would the way it is. If its any help you guys could share it will be appreciated.


Sent from my SCH-I545 using Tapatalk
 

·
REPOST Enforcement Mod
Joined
·
13,560 Posts
That's normal. The rear wheel will spin with the clutch disengaged if unloaded on a stand. The wet clutch spins in a oil. The oil in between the plates drags slightly and if the wheel has no tension on it to resist that, then it will spin. Especially when the oil and clutch plates are cold.

Pull in the clutch, my your foot on the rear tire to hold it, and see if it stops easily. Or light pressure on rear brake. If it doesn't stop really easily or the engine starts to change speeds from that, then you're dragging more than the oil and need to look into that. But just looking at the wheel spinning is not cause for concern.
 

·
Registered
Joined
·
946 Posts
make sure the pull lever inside the clutch cover isn't worn out too(lever part that pulls on the pull rod that pokes through the clutch hub).......it's easily overlooked but important to the overall mechanics of the clutch operation.
 
1 - 3 of 3 Posts
Top