Kawasaki ZX-10R Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i was just wondering if anyone else had any problems with clutch cables on they're 08? my cable snapped the other day and i went to order one and was told by 2 different dealers that the cable is on back order with no release date? I was told that there has been no problems reported about clutch cables yet but i can't figure out why they would be on back order if there is no problem? just wondering if my luck really is that bad.
 

·
Registered
Joined
·
239 Posts
yea my buddy has the same problem but his is about to snap and about to go out of warranty. he went ahead and ordered it but who knows when it gets in. we tried my 04 cable and it was a no go.
 

·
Registered
Joined
·
42 Posts
you know my clutch lever cable is a little loose and i have an 09 same body and frame. Sorry to jack, but is there a way to tighten it? or do i need to order some as well?
 

·
Registered
Joined
·
387 Posts
you have to make sure the cable sits in its channel after you make an adjustment up by the lever. its easy for the cable to fall into the groove after adjustment and if this happens repeated use will rub though the cable prematurely. i have almost 11,000 miles on mine now and it still works like new.
 

·
Registered
Joined
·
2,897 Posts
yeah I have no problems with mine and would like to know where they are breaking also im guessing its at the clutch lever area?? but im gonna check mine later and make sure I see no rub marks or anything of the such...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #11
yah there is some truth to the cable snapping, it snapped at the lever and no there aren't any rubb marks because i know how to properly adjust my cable. I have almost 14k on my bike. oh yah and the cables are on back order, i have better things to do all day then sit on the internet and make stuff up.....like trying to find a cable so that i start riding again and stop playing with the computer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #13
new cable on order from babbits.com, thanks suave ninja for the tip. they were the only ones who had it in stock. $32 to the door the only bad part is theye will not over night anything! i have to wait two weeks for it to get here but thats still a lot better than the wait from kawi. any way thanks again your a life saver!
 

·
Registered
Joined
·
4,603 Posts
you have to make sure the cable sits in its channel after you make an adjustment up by the lever. its easy for the cable to fall into the groove after adjustment and if this happens repeated use will rub though the cable prematurely. i have almost 11,000 miles on mine now and it still works like new.
10,000+ miles bike is running great! No cluch issues
 

·
Where'd the boobs go?
Joined
·
2,655 Posts
When is Kawi going to switch to a hydralic clutch so we don't have these cable issues anymore? I have 18xxx miles on my clutch cable and she is still as smoothe as butter. Lube baby, lube...
 

·
Registered
Joined
·
1,634 Posts
The clutch cable on my '08 occassionally would get hung up on the right side of the ram air duct when moving the handlebars left and right. This could cause some stress on the cable ends and cause them to break prematurely.

My solution was to zip tie the clutch cable to the upper part of the bracket by the ignition key. This prevents the cable from drooping down and interfering with the ram air duct.

I don't know if all Gen 3's are affected by this but mine had this issue. In my opinion it is a bit of a safety issue, because it could prevent your bars from turning easily to the left.
 

Attachments

·
Registered
Joined
·
265 Posts
Well 25k on my 2008 and my clutch cable snapped near the lever.... luckly i was leavin a a parking garage and not riding down the rode.... I was having the same issue as Rspec cable would always get caught up whe makn left turns.... dealer has one here for 27otd thankfully.... Checkin shop where i bought it for warranty claim though.... this is like the fourth thing that has broken or came loose on my bike since i bought new may of 2008.
 
1 - 18 of 18 Posts
Top