Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ladies and gentle giants,
I've got a 2017 zx10r with 3,400 miles on it currently. Over the last 2 days-ish I've noticed a burning plastic smell while sitting at traffic lights. Let me give you my current process of trying to find it..

Day 1 As stated, I noticed it at several stoplights... got home late and did some sniffing/searching to no avail and went to bed.

Day 2, I started it up this morning... let it get to about 160F, all is well, I take off for work.. once again at my 4 stoplights I noticed the burning plastic smell... get to work I parked it, I searched and sniffed everywhere...

all my wiring is good, plastics are good, headers and radiator are super clean, no signs of rub on the fan.. no signs of anything from the road wise on the bike, coolant and oil levels are good and brakes/rotors seem good... my buddy asked for me to start it up and let him sniff... let it idle to damn near 180F and nothing...

Once again on my way home though sitting at those lights I smell the plastic


Anyone else having issues with this??
 

·
Registered
Joined
·
34 Posts
A few questions.

Did you buy the bike new?
What are your most recent modifications?
What exhaust is on your bike? ( this may sound silly but make sure it’s not your boot melting a little on the pipe, it happens.)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Bike is almost stock, ecu flash and m4 street slayer... I'll certainly check my boot!!!

Nope the headers and exhaust were clean of anything bag-like


And I never thought it might be the soap I'm using 🤔🤔🤔🤔 I switch between a ceramic and a regular car wash with turtle wax (my most recent cleaning)... that may be it!! Thanks!
 
1 - 7 of 7 Posts
Top