Kawasaki ZX-10R Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
636 Posts
Discussion Starter #1
So I have been having so clutch issues. While trying to adjust it I noticed the outside spring has broke. The one on the lever the clutch cable goes onto. The part where it holds onto the clutch cover snapped off. What issues can this cause? Doesn't that spring help force the clutch back together? Can you buy just that spring? Any help is appreciated guys.
 

·
ZX-10R enthusiast
Joined
·
6,556 Posts
This one?



It returns the clutch lever back all the way...when mine broke I just adjusted my clutch perch to where it would return almost all the way when I let go. Just order the part OEM, it's easy to replace.
 

·
Registered
Joined
·
636 Posts
Discussion Starter #3
Yes that's the one. I didn't figure it was hard to replace. I'll have to get one ordered. My lever goes back in all the way so I think its fine then til I get a new one. Mine broke exactly like yours.
 

·
ZX-10R enthusiast
Joined
·
6,556 Posts
Yeah, not sure how it happened, I just figured I snagged it with my leathers or something :dontknow:
 

·
Registered
Joined
·
636 Posts
Discussion Starter #5
I have no idea either. I figured just wear. I had it happen on a 636 long time ago too but I never had any issues so didn't replace it. I spent way more on this bike so I want everything in perfect working order. I just wondered how important it really was.
 

·
Registered
Joined
·
254 Posts
Happened to my '11 as well. Dealer replaced it under warranty, but it took 3 months to get the parts for some reason.
 

·
Registered
Joined
·
1,906 Posts
Weird that that spring broke, not a big deal though to replace.
 

·
Registered
Joined
·
8 Posts
Ive had that spring broken since 4k miles and i remembered last week that i never fixed it, im at 12k miles now. :badteeth:
No clutch issues at all.
 

·
Registered
Joined
·
2,164 Posts
Would this broken spring cause a clutch slip problem??
Maybe?? If yours is broken just replace it, it's under $5

Don't use the fookin clutch.
If your fookin clutch is slipping your fookin hand doesn't need to touch the fookin lever.
 

·
Registered
Joined
·
26 Posts
Mine broke also about 4k miles ago, no issues. And barely used the clutch as I have a quickshifter and the bike is on 12k. The spring only collects the excess of the clutch cable, so if you have adjusted it correctly with 1mm play, keep it lubed and it wont need a spring at all. The clutch case has its own pair of springs which do their job with the friction plates. Correct me if I am wrong :)
 

·
Registered
Joined
·
1,906 Posts
Would this broken spring cause a clutch slip problem??
No, as long as you have adequate freeplay of 2-3mm at the clutch perch you are fine. Mine hasn't broken but I've considered taking it off.
 

·
Registered
Joined
·
1,906 Posts
Ha, mine broke on my '14 as well. Must be some crappy springs.
Yes, they are failing due to fatigue, probably improper heat treat during manufacture.
 

·
Registered
Joined
·
426 Posts
Leaving lunch the other day and killed it twice trying to leave.. was like wtf. Had to readjust clutch play to get it working back like the way i like it. Just noticed today that this spring is broken. Must of been what threw my clutch play out of wack.

Got new one on order.

Shipping cost more than the part.. :crying:

Kawasaki SPRING, RELEASE-COMP
Part number 92145-0325 $3.23
 

Attachments

1 - 20 of 20 Posts
Top