Kawasaki ZX-10R Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
552 Posts
Discussion Starter #1
Firstly, the bike has been running perfectly the last few thousand miles until now. I redline pretty often and change the oil about every 1.5k but anyway, here's the issue

Recently, the bike has started to miss and it's pretty violent. At first, I noticed it in 5th gear, last week, around 150mph, it's felt like the bike cut off (it didn't of course) for a split and cut back on. The rpms had dropped slightly and then went back to full throttle so it was a slight tug. Today it was a bit more violent. Wide open throttle in third gear around 120ish and it did the same thing but it happened twice, back to back. Two hard jerks due to the rpms dropping then going back to full throttle, I let off the gas immediately afterwards. Being the type of person I am, I kept riding to get a better feel for what was going on. About 10min later, I got on the gas hard in first and it did the same thing around 50mph but this was easily the most violent considering it's first gear :badteeth:. Felt like the bike was trying to do a clutch up wheelie. Any idea what this could be? Bike sounds fine and idles fine at the moment. It rides smooth whenever it's not being all jerky. I just hit 25k miles.
 

·
Registered
Joined
·
3,856 Posts
I had the same problem your describing turn out to be the side stand switch. I would check that see if yours is going bad.
 

·
Registered
Joined
·
552 Posts
Discussion Starter #5
Yeah, took it to a friend of mine and we found the safety switch to be an issue. I ordered a new one today. I wanted to bypass the safety switch but then I remembered the few times I kicked it into gear with kickstand down.... Although it wasn't many times, without the safety switch, I could've went down moments after during each incident.
 
1 - 5 of 5 Posts
Top