Kawasaki ZX-10R Forum banner

1 - 3 of 3 Posts

·
Newfie Bullet
Joined
·
2,341 Posts
Discussion Starter #1 (Edited)
bike quits or stalls!!

Hey guys..i got a question..
gen 2..the bike starts fine and runs normally,every now and then i have noticed the netural light flicker and bike stalls..I hit the start button and nothin..Doest that sound like the netural switch to you guys??
My gen 2 has been basically sitting sence last winter with the odd start up and battery charge and fresh fuel..
I spend to much time on the road and havent had the time sence this started to happen to look at it..
 

·
Registered
Joined
·
1,438 Posts
Hey guys..i got a question..
gen 2..the bike starts fine and runs normally,every now and then i have noticed the netural light flicker and bike stalls..I hit the start button and nothin..Doest that sound like the netural switch to you guys??
My gen 2 has been basically sitting sence last winter with the odd start up and battery charge and fresh fuel..
I spend to much time on the road and havent had the time sence this started to happen to look at it..
That's what it sounds like to me, but I'll be there's somebody else who will chime in that had this same problem before.
 

·
Newfie Bullet
Joined
·
2,341 Posts
Discussion Starter #3
Can anyone tell me for sure where im lookin for the netural switch on my gen 2...I see somethin ceramic looking just behind the front sprocket and its electrical..I looked through my manual and maybe im just missing it cause of a different name..I called a local dealer and they want $150 cdn to replace but he says there is a bunch of other electrical stuff to it as well..SOO im a lil lost..Any thoughts anyone...
 
1 - 3 of 3 Posts
Top