Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter #1
I have an 07 ZX10, The only performance mods are my Two brothers Single side exhaust. It does it at all temps outside, and if the bike is warm or hot. I pulled the tre off thinking that was causing it, didn't fix it. Changed the spark plugs and that didn't change it either. At high rpm around 11k the bike will cut out as if someone is turning the key off and on. I can't seem to figure out what it is. Oh, I also checked the tilt sensor and the kickstand switch and it still does it. Any help is greatly appreciated.
 

·
Registered
Joined
·
91 Posts
If your sure your not bounceing off the rev limiter, the fuel pump would be my suggestion. That is just a suggestion, don't run out and buy a new one till someone confirms.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #3
Yeah I'm sure its not bouncing off the limiter cause it sometimes struggles to get there. If it does get there its a slow bounce. The bike is down on power so I've got it in the shop waiting for a day to pull the take off and check the filter and also the vent tube. Hopefully I'll find an answer then.
 

·
Gen2 Ripper
Joined
·
4,867 Posts
Make sure you don't have a blockage in the tank sender(pet cock:spit:). Sounds like fuel starvation/lean condition. What did your plugs look like. Were they white? Light tan is what you want.

Compression test/leakdown.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #5
The plugs looked normal, more of a tan coloration no white to them. I gapped them and then replaced them and still no change. Hopefully its just something with the fuel filter.
 

·
Premium Member
Joined
·
4,392 Posts
Fuel pump ...

The only fuel filter is the inlet "bag" on the intake of the fuel pump inside the tank.
 

·
Registered
Joined
·
2,427 Posts
yeah, was thinking fuel pump/filter or lack of charge to cause a high rpm flutter.
 
1 - 9 of 9 Posts
Top