Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys. My battery won’t stay charged on my 2006 zx10r. I’ve replaced both the stator and regulator. It won’t turn over at all.
 

·
REPOST Enforcement Mod
Joined
·
14,390 Posts
Uhm, it would help to have a little more detail. If it won't turn over at all, why are you changing the stator/rectifier out? If the battery was replaced already and it won't turn over, it has nothing to do with the battery. So, is it an electrical problem? Or is a starting problem? So much information is missing.
 

·
Registered
Joined
·
311 Posts
If you replaced the battery and it wouldn't turn over then you have a problem electrically or your starter is done. Do you hear any clicking when trying to start?
 

·
Registered
Joined
·
311 Posts
Thats good news. Disconnect one of the battery cables so its not sending current through the bike and check the connections at the starter. It has a positive and negative cable hookup so double check those to make sure theyre not loose. Also check where the ground cable attaches to the engine block or wherever and make sure that isnt loose. If that dont work give the starter a couple wacks with a hammer and see if she turns over.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Uhm, it would help to have a little more detail. If it won't turn over at all, why are you changing the stator/rectifier out? If the battery was replaced already and it won't turn over, it has nothing to do with the battery. So, is it an electrical problem? Or is a starting problem? So much information is missing.
Sorry before you do all that look at the starter relay to make sure its good lol.
ok. Lol
 

·
REPOST Enforcement Mod
Joined
·
14,390 Posts
Yes I hear clicking when I try to start it.
Is the clicking one time? Is it just repeatedly clicking? You're hearing the starter relay clicking. Did you charge the battery after you got it? Or did you just drop it in? What battery is it?
 
1 - 10 of 10 Posts
Top