Kawasaki ZX-10R Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #1
OK guys. '09 10R holdover, purchased new in mid December 2010. 310 miles. Have driven it every 1-3 days, short runs, 10-30 miles, for the past 3 weeks. No battery tender.

Bike has cranked every time. Drove approx. 30 miles today, stopped and filled up w/ gas. Bike wouldn't crank. Had it hauled in. Battery dead. Bike would jump start.

Dealer is currently recharging the battery and checking out the charging system.

Service manager mentioned they had some rectifier problems on the '09.

Is there anything else I can tell this guy to look for? Are there any charging / battery problems you have had?

Thanks in advance.
 

·
Registered
Joined
·
4,603 Posts
I have heard a few new 09 GEN III's have the battery die on them and it happens quick. My guess is because the bike sat with no tender on it for over a year.

Purchased my GEN III in March 08 and the battery died on me in 2010. Bike had about 18K miles at the time.

I have not heard of any wide spread electrical problems with the GEN III.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #3
I have heard a few new 09 GEN III's have the battery die on them and it happens quick. My guess is because the bike sat with no tender on it for over a year.

Purchased my GEN III in March 08 and the battery died on me in 2010. Bike had about 18K miles at the time.

I have not heard of any wide spread electrical problems with the GEN III.
The battery was never filled w/ acid and charged until I purchased the bike. The dealer represents this as a new battery. I don't know what the shelf life is on a dry, uncharged battery.

I appreciate your response.

Thanks
 

·
Registered
Joined
·
328 Posts
To funny just had the same thing happen to me today. Have been riding it to and from work with no problems. Went out today for a 4hr ride and towards the end the battery just quit. Bike would not turn over. I had to bump start it then on the way home received a FI light. Dealer will call monday to see what to do. I have a brand new 09 too has about 800 miles on it bought it last month. So we will see.
 

·
Registered
Joined
·
4,603 Posts
The battery was never filled w/ acid and charged until I purchased the bike. The dealer represents this as a new battery. I don't know what the shelf life is on a dry, uncharged battery.

I appreciate your response.

Thanks
I feel your pain bro

When you find out what the issue was please let us know...

I Would hate to be out on a ride and get stuck

When my battery died I was 60 miles from home it was a nightmare;

http://www.zx-10r.net/forum/showthread.php?t=87041
 

·
Registered
Joined
·
212 Posts
Discussion Starter #6
Turns out the rectifier went out. Going to take a week to get one in from kawasaki.

Chaps my ass they reportedly have problems with the rectifiers and don't deem it necessary to stock one??:dontknow:

I hope this takes care of the problem.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #7
To funny just had the same thing happen to me today. Have been riding it to and from work with no problems. Went out today for a 4hr ride and towards the end the battery just quit. Bike would not turn over. I had to bump start it then on the way home received a FI light. Dealer will call monday to see what to do. I have a brand new 09 too has about 800 miles on it bought it last month. So we will see.
CULTR.

Fried rectifier. One week wait on parts.

Wanna bet you have the same problem?

Let me know if it's something different so I can have the service dept. check it out also.

Thanks
 

·
Registered
Joined
·
212 Posts
Discussion Starter #8
I feel your pain bro

When you find out what the issue was please let us know...

I Would hate to be out on a ride and get stuck

When my battery died I was 60 miles from home it was a nightmare;

http://www.zx-10r.net/forum/showthread.php?t=87041
It's really no big deal. It was a beautiful day and I needed the exercise pushing the damn thing.

I used to ride British bikes and Harleys. I am used to being stranded:eek:ccasion1
 

·
Registered
Joined
·
4,603 Posts
It's really no big deal. It was a beautiful day and I needed the exercise pushing the damn thing.

I used to ride British bikes and Harleys. I am used to being stranded:eek:ccasion1
Good one:mrgreen:.

Glad they figured it out should be warranty repair :eek:ccasion1
 

·
Registered
Joined
·
328 Posts
Well Its day 3 the dealer has my bike and no word on whats wrong with it. They say there still looking into it. Maybe it was pushed to the back and looked at here and there due to it being under warannty. We will see.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #11
Well Its day 3 the dealer has my bike and no word on whats wrong with it. They say there still looking into it. Maybe it was pushed to the back and looked at here and there due to it being under warannty. We will see.
I just went by the dealer and found they just finished up. They said they put in the new rectifier, checked the battery and charging system out and everything was good to go. I'll pick it up in the AM.

Everything was covered under warranty. They wouldn't reimbursement for my $85 towing charge.
 

·
Registered
Joined
·
328 Posts
Well the Stealership called me today said it was a bad rectifier. They ordered a new one should be in next week. Hope this one last longer than 900 miles.
 

·
Registered
Joined
·
137 Posts
Triple A

You might know this (here in Oregon) I have the plus membership and cover
my car & motorcycle up to 200 miles. Last time I used it I saved $360.00 dlls:eek:ccasion1
 

·
Registered
Joined
·
212 Posts
Discussion Starter #14
You might know this (here in Oregon) I have the plus membership and cover
my car & motorcycle up to 200 miles. Last time I used it I saved $360.00 dlls:eek:ccasion1
I'll have to check on that. I have my cars listed w/ AAA, but not my bike.

I don't have towing on my Geico because I don't carry collision.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #15
Well the Stealership called me today said it was a bad rectifier. They ordered a new one should be in next week. Hope this one last longer than 900 miles.
Exactly same as mine. What they couldn't tell me is if the electrical system fried the rectifier or it just went bad.

I drove mine home yesterday.....in 22F weather. Talking about cold!!!
 

·
Registered
Joined
·
755 Posts
You's guys have got me all paranoid with my 09 noooaw! Nearly 12,000miles on mine so far without probs, hopefully it stays that way:wink:
 
1 - 16 of 16 Posts
Top