Kawasaki ZX-10R Forum banner
1 - 8 of 8 Posts

·
Chickenstrip Eater
Joined
·
4,075 Posts
Discussion Starter · #1 · (Edited)

·
Registered
Joined
·
112 Posts
I have some and overall it is a good unit. The lower will not fit with the stock exhaust though. I worked with the company and they tried to resolve the problem but I gave up after about 6 months of sending them pictures. They did send me a "fixed lower" but it still does not fit. Other than the issue with the lower I was pleased with the fit. It was also a scuff and shoot paint finish so thats a plus. I just did a rattle can but looks ok for track time.
 

·
Chickenstrip Eater
Joined
·
4,075 Posts
Discussion Starter · #3 ·
Got a pic? Thanks for the input, I'd like to know where exactly the problem is with the lower. Seems like Hotbodies or Chineese Ebay stuff are my only other options in this price range, and neither get great reviews. Is it the cat converter that rubs?
 

·
Premium Member
Joined
·
4,394 Posts
Plenty of people use Armor Bodies around here.
 

·
Registered
Joined
·
112 Posts
Like I said it is a good product, but both Bigprfed22 which is a member here and myself had trouble fitting the lower with the stock exhaust. We both finally just cut the lower out to fit the factory exhaust. We both worked directly with Armour Bodies in Canada trying to resolve the problem. We both run it on 06's though. What are you putting it on? I will try to take a few pics tomorrow but check Bigprfed22 he has posted a few pics in a few previous post of the problem areas. But like i said earlier it is a quality product other than the small issue we had.
 

·
Registered
Joined
·
411 Posts
Armor bodies are a good quality product. I used them on my R6 and the fitment was about perfect! Very minor prep work, paint adhered well to the primer. Best plastics out there for the money.
that look shmick! :thumbsup:
 

·
Chickenstrip Eater
Joined
·
4,075 Posts
Discussion Starter · #8 ·
Like I said it is a good product, but both Bigprfed22 which is a member here and myself had trouble fitting the lower with the stock exhaust. We both finally just cut the lower out to fit the factory exhaust. We both worked directly with Armour Bodies in Canada trying to resolve the problem. We both run it on 06's though. What are you putting it on? I will try to take a few pics tomorrow but check Bigprfed22 he has posted a few pics in a few previous post of the problem areas. But like i said earlier it is a quality product other than the small issue we had.
It's an 07 10r. Thanks to all who replied. Guess that's the route I'll be going.
 
1 - 8 of 8 Posts
Top