Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
974 Posts
Discussion Starter #1
Good day of drag racing, but ate 2 clutches in 8-12 passes...

Tried different static springs, but the motor just kept blowing through them.....tried the same setup from last year that worked flawlessly, but the new motor power is a bit much.

Anyone with some spring setting ideas?

I have a selection of springs to choose from.
 

·
Registered
Joined
·
65 Posts
clutch

Good day of drag racing, but ate 2 clutches in 8-12 passes...

Tried different static springs, but the motor just kept blowing through them.....tried the same setup from last year that worked flawlessly, but the new motor power is a bit much.

Anyone with some spring setting ideas?

I have a selection of springs to choose from.

Did you get this sorted out yet?? I need to set one up for my ZX10 also. I've got on in my old school KZ no bar bike and it works ok. I used the stock springs for the static and then mixed light and heavy springs for the second stage. I used just a nut and bolt on the final. Seems to do ok for me but i plan to try a few different combinations. I do spray a good size shot of nitrous progressively down track to run the Crazy 8's index so the clutch really has to fully lock up when the spray comes on.
 

·
Registered
Joined
·
65 Posts
clutch

MTC wasn't much help. Try to post this on psychobike.com. Someone on there can give you a better starting point. If its burning up the clutches then the second stage springs could be too stiff keeping the arms from locking up the clutch. I would either add weight to the arms or try softer inner springs. Just my 2 cents.
 

Attachments

·
Registered
Joined
·
974 Posts
Discussion Starter #4
yea, i addressed some issues, and tried new launching technique with HD springs without the lockup setup.....in a couple weeks i'll be re-trying the lockup and see where i'm at.
 
1 - 4 of 4 Posts
Top