Kawasaki ZX-10R Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
For about a month (or more) I've been having problems that I haven't been able to track down. Hard starts, no fast idle at cold start and between 3K and 4K the bike would hesitate and stumble. It happened shortly after I installled my TRE, so naturally I removed it and reset the sub throttle, not the problem. It seemed like everytime I reset the throttle position it would run well until I shut it off and the bike cooled. So this weekend I took the PCIII out and lo and behold the bike ran great, no stumble between 3K and 4K, fast idle came back and it starts on the first push of the starter button.

All of this it to say, could this be a problem with the PC or just a result of not having a custom map?

P.S. the bike is stock other than the PC and I tried several different maps, from the stock map at PC's website to Ivan's map that came with the TRE.?
 

·
Registered
Joined
·
5,228 Posts
I had a problem with my pcIII. My bike would only rev to 11k rpm. I took it out and it ran fine. Re-installed it and it ran like shit again. I had my friends with the dyno reset it on their computer. Its some special key you have to push and a box will appear asking if you want to reset the powercommander.
 

·
Registered
Joined
·
477 Posts
not really the same deal as this though. Yes the prob I would say is the mapping. You've tried various maps, and there are thousands more, why do you think that is exactly? Coz they are all different. Get it custom mapped and you'll be sweet. The PC is for the very purpose of making your air/fuel spot on everywhere, yet you're only muckin around with half arsed versions of what it is capable of doing.
 

·
Registered
Joined
·
3,449 Posts
Birdman said:
not really the same deal as this though. Yes the prob I would say is the mapping. You've tried various maps, and there are thousands more, why do you think that is exactly? Coz they are all different. Get it custom mapped and you'll be sweet. The PC is for the very purpose of making your air/fuel spot on everywhere, yet you're only muckin around with half arsed versions of what it is capable of doing.
:+1:

I had thesame problems whenever I cruise about 3-4000 rpm throttle closed and grab the clutch engine stumbles and sometime engine cuts off with the power commander without the pc runs fine.I've reset the throttle several times same thing.
 

·
MIA Ex-Mod
Joined
·
3,051 Posts
And while your getting the custom map done have them reset the PC and then build the map, just incase.

Tread
 

·
Yankee Racer
Joined
·
14,838 Posts
Birdman said:
not really the same deal as this though. Yes the prob I would say is the mapping. You've tried various maps, and there are thousands more, why do you think that is exactly? Coz they are all different. Get it custom mapped and you'll be sweet. The PC is for the very purpose of making your air/fuel spot on everywhere, yet you're only muckin around with half arsed versions of what it is capable of doing.
+1 to that. I have a custom map and let me tell yah the bike is amazingly smooth and I have had no problems:thumbsup:
 

·
Green Hippie
Joined
·
17,566 Posts
zx10ragentblack said:
+1 to that. I have a custom map and let me tell yah the bike is amazingly smooth and I have had no problems:thumbsup:
same here I have a custom map and slip on Akra exhaust ,my friend has a full Akra exhaust system no map just the PC111 and he only has 3 more HP on the same DYno :mrgreen: get that thang mapped
 

·
Registered
Joined
·
735 Posts
Yeah I would get a custom map made.. Me I got lucky and the one I downloaded worked ok untill I got it remapped. On the other hand, My buddys R1 wouldnt run for shit with 6 different maps untill he got it custom mapped on a dyno..
 

·
Registered
Joined
·
1,428 Posts
colinmitchell111 said:
Yeah I would get a custom map made.. Me I got lucky and the one I downloaded worked ok untill I got it remapped. On the other hand, My buddys R1 wouldnt run for shit with 6 different maps untill he got it custom mapped on a dyno..
Part of that could be that it is a R1.
LOL
 

·
Rent this space
Joined
·
6,590 Posts
My PC111 loses the map if I leave the bike for too long, POS, switching to Kawasaki programmable stuff soon.
 

·
Registered
Joined
·
250 Posts
Problems also!!

My bike runs great below 10500....then it breaks up and runs terrible..sounds awful...
I have tried various maps from lean to rich...I ordering a datalogger with a/f that will be here this week....
BUT I want to have my PCIII reset....Killer do you think you could find out how to do it??? Does anyone know??
Someone out there knows how...please chime in...

I have the following...
Akra EVo2,PCIIIUSB,Schnitz EFIR,BMC race,40 shot nitrous,airbox mods,16/41 gearing,1/5 turn throttle,low friction bearings,thin head gasket,kaw intake cam,cams degreed to 105/105,and its stretched and slammed...

ANY IDEAS???
Thanks
 

·
Registered
Joined
·
735 Posts
madkaw said:
Part of that could be that it is a R1.
LOL

:werd: fuckin yammys.....
 

·
Registered
Joined
·
448 Posts
i have a 06 zx10r and i have the single two brothers exhaust,tre,pc 3 on my bike it seems to run good as long as you are on the throttle but at idle it surges,I called my local dealer ship the guy told me i needed a block off plate,well i called two brothers they told me my bike and exhaust didnt need a block off plate,i got my pc 3 from fuel moto wich was a premapped thing so i dont no how that works,did any body eslse have to put anykind of plates when putting your after market exhaust on the 06 please let me no thanks
 

·
Registered
Joined
·
186 Posts
I faced cut-offs,stalling with my pciii.before u make any othr move,rev the bike in neutral 3 times to the redline cut-off limiter.it seems this make a reset.
ATTENTION**EVERY TIME U DISCONNECT THE PCIII PLUGS-EVEN WITH ENGINE OFF(OFCOURSE),THE PCIII LOSES THE MAP.-It happened to me twice!!!!!!!!!!!!!
 

·
Registered
Joined
·
3,449 Posts
I figure out my problem I too was having cut off problem during deceleration I adjusted the deceleration. I lowered the deceleration and up the acceleation. I was reading the 04 service manual available here i this site try search. Did sent my powercommander back still having the issue so my next set was to check the bike coz it's not the powercommander. Adjusting your throttle cable would slow down the deceleration even with the backfire the idle will stay. I hope it would for you guys.
 
1 - 18 of 18 Posts
Top