Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
My PC3 on my Gen1 stopped communicating with the laptop while trying to upload a map, until I clicked on "send map" it communicated fine. Now it says "No power commander" and the laptop will not communicate with the PC3. The laptop makes the noise when you hook up a new USB cable to it so it should be seeing the PC3. Lights are fine on the PC3 and the green stays lit after the lights do their dance on the start up, the connections to the PC3 are good but I will re-check those again.

I tried with bike running and also with the 9V battery, no go. The bike was running when I was uploading the map and it stopped communicating.
Re-installed the power commander software in the laptop, no go.
I tried with a different laptop, no go.
I tried a different Gen2 PC3 with a 9V not on the bike and it communicates fine with the laptop same USB cable same PC3 software on the laptop.

I am stumped, any pointers? Any way to hard reset the PC3 or how to get it to communicate? What am I missing?
 

·
REPOST Enforcement Mod
Joined
·
14,973 Posts
Uh, well the bike should be ON, but not running when you upload a map. The PC3 should have power applied to it to communicate, but it shouldn't be actively trying to interface with the bike electronics during this. So, it's likely corrupted now since it was trying to run the bike at the same time as updating the software that was used to run the bike.

First thing you should do is update and reinstall the firmware on the PC to see if that would work.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #3
Uh, well the bike should be ON, but not running when you upload a map. The PC3 should have power applied to it to communicate, but it shouldn't be actively trying to interface with the bike electronics during this. So, it's likely corrupted now since it was trying to run the bike at the same time as updating the software that was used to run the bike.

First thing you should do is update and reinstall the firmware on the PC to see if that would work.
What's the trick to get the PC to communicate with the laptop to reinstall the firmware? Catch 22, Can't communicate can't reinstall. I haven't frigged with a PC for a while but from what I remember I use to be able to "send map" fine and play with the numbers while the bike was running.
 

·
REPOST Enforcement Mod
Joined
·
14,973 Posts
What's the trick to get the PC to communicate with the laptop to reinstall the firmware? Catch 22, Can't communicate can't reinstall. I haven't frigged with a PC for a while but from what I remember I use to be able to "send map" fine and play with the numbers while the bike was running.
Indeed. But the communication part is different when sending a map to it versus trying to load the firmware on it. Have you actually tried loading the firmware on it or just looking at the problem from the point of "not being able to load the map" on it? If you can't load the firmware then there's no way that I'm aware of to just reset it. That's the point of the firmware load to try and basically reset it if that got corrupted somehow. The other thing to try is a different USB port on your computer than what you've been using.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #5
Indeed. But the communication part is different when sending a map to it versus trying to load the firmware on it. Have you actually tried loading the firmware on it or just looking at the problem from the point of "not being able to load the map" on it? If you can't load the firmware then there's no way that I'm aware of to just reset it. That's the point of the firmware load to try and basically reset it if that got corrupted somehow. The other thing to try is a different USB port on your computer than what you've been using.
I tried every USB port and just to be sure tried a different laptop altogether with no luck. I am not familiar with doing the firmware update but I tried and the thing your suppose to click on for the firmware isn't clickable or may be I couldn't figure it out cuz I got too frustrated. Any pointers for the firmware update and which file is the right firmware for Gen1?
 

·
REPOST Enforcement Mod
Joined
·
14,973 Posts
I tried every USB port and just to be sure tried a different laptop altogether with no luck. I am not familiar with doing the firmware update but I tried and the thing your suppose to click on for the firmware isn't clickable or may be I couldn't figure it out cuz I got too frustrated. Any pointers for the firmware update and which file is the right firmware for Gen1?
Go here to download:

Power Commander Downloads
 

·
Registered
Joined
·
101 Posts
Discussion Starter #7
Got a new USB cable and communicates good now. Tried to do the firmware update error code 42 and 11. Didn't had a problem uploading the map and setting throttle position so I don't know if I wana pursue a firmware update. Looks like it was the cable that was the culprit even though that cable was working before and still works with the other Power Commander :dontknow:. Thanks for the help bud, appreciated.
 

·
Registered
Joined
·
2,161 Posts
Step 1. Pull the power commander from your bike.
Step 2. Throw it in the trash can,or give it to the guy that you really hate lol.
 

·
Registered
Joined
·
2,161 Posts
LOL, what do you suggest instead of a PC?
It's 2017, you can tune your factory ecu, or you can use a stand alone ecu that will do just about everything, or you can run nothing, still better than running a power commander. Just google on the fail rate of power commander, you can read complaints for 2 years straight lol.
 
1 - 10 of 10 Posts
Top