Kawasaki ZX-10R Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Has anyone else had a problem with the clutches grabbing when you are launching in high rpms. Its like i get one or two good races before the clutches just start grabbing, so I end up standing the bike up or spinning.
What did you do to help with this problem? Maybe I'm the only idiot...
 

·
Registered
Joined
·
1,561 Posts
jayreal said:
Has anyone else had a problem with the clutches grabbing when you are launching in high rpms. Its like i get one or two good races before the clutches just start grabbing, so I end up standing the bike up or spinning.
What did you do to help with this problem? Maybe I'm the only idiot...
zx-10 clutches get dry very fast that could be part of the problem but it could also be the rider:dontknow:
 

·
Registered
Joined
·
4,049 Posts
Vince10R said:
zx-10 clutches get dry very fast that could be part of the problem but it could also be the rider:dontknow:
:+1:

I'd say the fibers are getting dry. Try leaning the bike over to the clutch side before a pass and see if that helps. :thumbsup:
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
Ruthless Racing said:
:+1:

I'd say the fibers are getting dry. Try leaning the bike over to the clutch side before a pass and see if that helps. :thumbsup:

I'll try that and see how it goes. As for the "practice", I don't think I can ever get enough practice, so you're right also. I'm not completely new to drag racing either though. I just wanted to see what sort of tips and tricks you guys with more experience on the zx10r at the dragstrip would have for me. I learn alot from you guys.
 

·
Registered
Joined
·
4,049 Posts
jayreal said:
I'll try that and see how it goes. As for the "practice", I don't think I can ever get enough practice, so you're right also. I'm not completely new to drag racing either though. I just wanted to see what sort of tips and tricks you guys with more experience on the zx10r at the dragstrip would have for me. I learn alot from you guys.
Seat Time is key. :helmet: Good Luck and let us know if that helps!!!:thumbsup:
 

·
Registered
Joined
·
1,561 Posts
Ruthless Racing said:
:+1:

I'd say the fibers are getting dry. Try leaning the bike over to the clutch side before a pass and see if that helps. :thumbsup:
:+1: yeah what he said. Id bet though that they are just getting dry. I talked with Dwayne at cycle concepts about some ways we may be able to remedy this. Will let you guys know how it works out.
 

·
Registered
Joined
·
4,049 Posts
Vince10R said:
:+1: yeah what he said. Id bet though that they are just getting dry. I talked with Dwayne at cycle concepts about some ways we may be able to remedy this. Will let you guys know how it works out.
I think you talked to me about it at The Rock too:dontknow:
 

·
Registered
Joined
·
1,041 Posts
just like ruthless said, probably dry...I'm doing my clutch this weekend...got alot of info from vonstallins walk thru . Roughly around 20 dragstrip passes and 6k miles.
 

·
Registered
Joined
·
4,049 Posts
Vince10R said:
yeah I will let you know what we find
:thumbsup: Very good idea for someone that doesn't want to be in there clutch often.
 

·
Registered
Joined
·
448 Posts
Wow, with the soft spring pressure in your lock-up, I didn't think it would chatter off the line.....????
I have NEVER ridden a big Suzuki that DID NOT clutch chatter on a hard launch. (GSXR 750+1000) The Brock's Cushion kit is supposed to stop this.? The ZX10 that I ran never chattered, but it was stock legenth. I know the Kawi 10 clutch has the two "steels" held together with springs that is supposed to prevent chatter as well. (?) Is yours still in place?
I have had a CBR1000RR chatter, and my 954 does if the "judder" spring is removed.
 

·
Registered
Joined
·
251 Posts
Are u running factory clutches, if not, thats your first problem. If yes, you may have some fibers and steels stuck together, pull your clutch stack out and clean up the steel plates, soak the fibers while you do that and then put them back in.
 

·
Slow Poke
Joined
·
5,584 Posts
I had a problem last year with my clutch, when I would try to slip it, it wouldn't grap very well, then I would try to not slip as much and leave a little harder and it would just stand up, like there was no happy medium. we put a Barnett in and a stiffer spring every other one and it seemed to help a little bit. any one with the same??
 
1 - 20 of 21 Posts
Top