Kawasaki ZX-10R Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter · #1 ·
Trtying to ground whatever wire for the self diagnosis so i grounded all 1 by one in the clip and now my heads up display wont turn on
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #2 ·
Siigh

Disregard agter crying thinking i broke my baby even more i discovered a burnt fuze
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #4 ·
0

You see i did and it only told me to put it on odo and press the reset button but nothing happens
 

·
Registered
Joined
·
1,276 Posts
might be cheaper for you at this point to just take it to a dealer and let them fix it.....
 

·
Registered
Joined
·
1,730 Posts
Refer to the service manual for diagnostic codes and procedures. But I want a heads up display!
haha hell yeah. no more looking down.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #7 ·
pwahahah and lose my pride? ... okay only if this new ignition switch doesnt work sigh...... thanks for yalls replies
 

·
Registered
Joined
·
1,276 Posts
pwahahah and lose my pride? ... okay only if this new ignition switch doesnt work sigh...... thanks for yalls replies
loose your pride? Shit...your throwing parts and money @ this.... I think I can suck it up and say "I dont know whats wrong with it" and then save some $....
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
No doubt !!

It's one thing to try and fix your own stuff but, when you are out of your

league, man up and say, "I don't know what I'm doing here".

Take that fine machinery to someone who does know what they are doing and

let the pro's fix it right. No shame in that. At least you tried.


JMTC
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #10 ·
1

true true i will do so on my next paycheck because i have no idea how much it will run me being i know nothing of what kind of a problem it is hopefully it will be something small
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
:thumbsup::thumbsup:

Good luck bro,

Hopefully it won't cost a bundle.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #12 ·
nope it was the ignition switch and my idle adjuster shes running like a champ now if i only had rear brakes id be set
 

·
Guilty by association
Joined
·
8,751 Posts
i suppose its a lesson learned when you do it yourself. sometimes we have to learn things the hard way. glad you got it running good
 

·
Dont mess wit White Ninja
Joined
·
5,932 Posts
good luck!!! I doubt it costs more then a half hour of work which is about 50 bucks normally where ever you go!!
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
Good deal :thumbsup::thumbsup:

I'm glad it was an inexpensive fix for you.

It pays to take it to the dealer sometimes.
 

·
Registered
Joined
·
641 Posts
careful with electrical stuff. I used to work for a motorcycle electronics company. And I'm still baffled/nervous when doing electrical stuff on my bike most of the time. That, and I'm colorblind. Thank the good Lord that on my X-TRE install, they gave not only wire color but pin location. Red and brown are indiscernable to me...as well as a bunch of other colors =(
 

·
Registered
Joined
·
1,978 Posts
dude u dont ground random wires thats not how a circuit works ur lucky the fuse only blew. the ground can be diff colors check ur specs
 
1 - 19 of 19 Posts
Top