Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Registered
Gen 1 Spark Black and HP4 Competition.
Joined
·
125 Posts
Discussion Starter #1
What calipers are you guys running on your Gen 1s.

Had the bike out on a maiden low speed run, took her back out today and ran her up to 160 plus in places.. the front brakes are annoying me, although the stopping power is phenomenal with the upgraded discs and HH pads the pads are clicking like mad in the calipers when pressure is applied, this seems to be a common issue with Earlyish R1 Calipers.

I can actually see the pads rise against the abutments on the inside of the calipers when up on my ramp and axle stand in use as I spin the wheel and apply the brake lever, on the road it's most noticeable at slower speeds.

Pulled the pads, pins, springs, everything as it should be, but as I had suspected when building them up in the 1st place the pads slipped into place easily perhaps too easily.

Cheers



Sent from my SM-G975F using Tapatalk
 

·
Registered
Gen 1 Spark Black and HP4 Competition.
Joined
·
125 Posts
Discussion Starter #2
Looks like I'm stuck with this clicking, stripped everything apart, loosened caliper bolts and refitted, I made sure the calipers were square by using a zip tie on the lever before nipping up, the rhs disc/pads were showing uneven wear albeit after just 30 miles.. the clicking remains I can get a 0.75mm feeler between the abutments and back plates which I feel is excessive by about 0.5 mil..


Sent from my SM-G975F using Tapatalk
 

·
Registered
Gen 1 Spark Black and HP4 Competition.
Joined
·
125 Posts
Discussion Starter #4
Click, pads ride up in the caliper when brake is applied.. common on these calipers... annoying as hell.

Sent from my SM-G975F using Tapatalk
 
1 - 4 of 4 Posts
Top