Kawasaki ZX-10R Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Basically my zx-10r has been sitting for about a year, maybe longer. there has been gas in the tank the hole time with a fuel stabilizer. I used a starter spray to give it a jump start but it only runs for a few seconds then stalls. whats my next step? Are my fuel injections Claugged up? Im not sure what to do next, my bike has always started up right away for as long as I had it. Also I FI light is on. Thanks in advanced.
 

·
Registered
Joined
·
8 Posts
The fi light is blinking so pulling codes would tell you what exactly is wrong with the bike - on the 05, you might have to go to the dealer unless someone on here knows a trick. It's similar to a car's check engine light - it's a generic warning to tell you that is wrong - pulling codes will tell you exactly what's wrong. When the codes are pulled, a number or multiple numbers are given and then with those number, you can tell what is wrong with your bike.

If I were in your position, I'd empty the tank, disconnect all the fuel lines, blow some air through those lines to see if they're plugged...if all is well after that, put some seafoam in there and some fresh fuel...If your bike has been sitting for that long, the fuel could have gelled-up. If that doesn't work, you might be looking at bringing your bike to a mechanic who has the right tools to pull codes. Hope this helps.
 

·
Registered
Joined
·
55 Posts
Um, stating the obvious first. Is your battery charged fully? If so, how about the alternator? It wont run if the alternator (stator, whatever...it's the same thing) is busted.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #11
wow thanks for all the help guys.

Ill empty/clean the gas tank first and clean the lines. and see how that goes. And go from there.
 

·
Registered
Joined
·
86 Posts
try this

wow thanks for all the help guys.

Ill empty/clean the gas tank first and clean the lines. and see how that goes. And go from there.
if after warming up it dies try a charged battery? if so it can be the whole charging system as happened to mine, stator, etc etc....
 
1 - 12 of 12 Posts
Top