Kawasaki ZX-10R Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
905 Posts
Discussion Starter #1
I just received my led bulbs to replace the city lights in my gen I. I got the red ones seen here http://www.superbrightleds.com/cgi-bin/store/index.cgi?action=DispPage&Page2Disp=/mini-wedge.htm I got the ones with High Power SMD LEDs. l I installed, they look amazing, but then reading the bag they came in, it said not to install in headlight housing due to heat damaging your headlights. Anyone used these same bulbs? Should I get different ones or what? Any help is appreciated. thanks!
 

·
Registered
Joined
·
905 Posts
Discussion Starter #3
suck is a light way of putting it. I thought I read up here someone had used those exact bulbs, maybe I am mistaken
 

·
REPOST Enforcement Mod
Joined
·
13,549 Posts
Used those bulbs in my '06 and went through 2 sets of them inside of 6 mos. They suck. Well, for this use anyway. There's no risk of melting your housing or anything crazy like that, but the heat build up in the housing from the headlights will cause the LEDs to stop working. Several threads on this issue in the past.

The bulbs you need to be using can be acquired from eBay. Search "194 SMD" and you'll get all sorts of bulbs in different colors. Got mine set from somewhere in China for like $6.99 for the 2 of them. I've had them for 3 years now and still running strong with my HIDs.

Look here as well:
http://zx-10r.net/forum/showthread.php?t=90062
 

·
REPOST Enforcement Mod
Joined
·
13,549 Posts
OK....well, re-reading your post, I see you already got the SMD type. If that's the case, you should be OK. It's the regular superbrightled lamps that are the issue. You should be good. Sorry for my previous post.
 

·
Registered
Joined
·
2,105 Posts
Its just a disclaimer I ordered mine from them just last week and it said the same thing. Also I must note I don't have the smd. I'm not gonna worry about them at all.
 

·
Registered
Joined
·
905 Posts
Discussion Starter #12
Thanks guys. I thought this might be a corporate disclaimer, but I did get worried. I got the high power smd leds, and it sounds like they are the correct ones.
 

·
Newfie Bullet
Joined
·
2,341 Posts
I bought my running lights in a trk stop..Had them in my gen 2 and transferred them to my gen3..no probs..
 

·
Banned
Joined
·
347 Posts
Just did mine last night in my 2Gen. city lights and tag light. Did some smancy wiring to get that tag right but it works a charm. Have had these in all my bikes with no problems
 
1 - 15 of 15 Posts
Top