Kawasaki ZX-10R Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So out of nowhere I have no rear brakes basically and front brakes would get spongy after awhile and the lever would travel a ways before the brakes actually start to kick in. I tried bleeding all the brakes and still. No rear brakes and the fronts would be stiff for a little then get spongy again. Any idea what to check or do
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,808 Posts
Welcome!

I would assume based on this that you have an ABS version. Otherwise, there is no way possible for the front to affect the rear as they are completely separate. If you have this issue and you have ABS, then that's the first place to start looking at the ABS hydraulic unit.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Welcome!

I would assume based on this that you have an ABS version. Otherwise, there is no way possible for the front to affect the rear as they are completely separate. If you have this issue and you have ABS, then that's the first place to start looking at the ABS hydraulic unit.
Welcome!

I would assume based on this that you have an ABS version. Otherwise, there is no way possible for the front to affect the rear as they are completely separate. If you have this issue and you have ABS, then that's the first place to start looking at the ABS hydraulic unit.
yes it’s the abs one and where would I locate that.
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,808 Posts
yes it’s the abs one and where would I locate that.
Well, you should follow the brake line routing to it. It's what controls the brakes. They all go to that one central place on the left side of the motor behind the #1 cylinder.


Off the grid
 

·
Registered
Joined
·
136 Posts
Might want to try a sintered pad on front, I use Braking,, and it is an improvement.
My back are also just for show..
On my ZX 14, I removed the small anti rattle brackets from the front calipers. Noticeable better braking, and yes the pads rattle slightly.. Also going to remove it from the rear to test..
 

·
Registered
ZX10RR
Joined
·
395 Posts
Easy fix could be getting an abs dongle and disable the abs entirely, it'd be a good test at least !
 

·
Registered
Joined
·
136 Posts
Easy fix could be getting an abs dongle and disable the abs entirely, it'd be a good test at least !
I have the dongle, but not tried it yet,, although recently i am getting into situations where i feel the abs is hindering me with an uneasy feeling when braking hard.
 
1 - 7 of 7 Posts
Top