Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I drag race my 2011 zx 10R I recently switch the clutches to 2004 -2005 clutches.Everybody said they would work in my bike and a lot of the people at the track have them. And said it would make your launch smoother . But now that I have changed the clutches the bike has a horrible bog.It literally just falls on its face when you let go of the clutch from 10000 rpm .Someone told me that I was not holding the clutch long enough so I held it longer and it didn't bog as bad but it still bogged and it killed my 60ft time. Any ideas on how to fix it Or should I just go back to my 2011 clutches ?
 

·
Registered
Joined
·
338 Posts
I drag race my 2011 zx 10R I recently switch the clutches to 2004 -2005 clutches.Everybody said they would work in my bike and a lot of the people at the track have them. And said it would make your launch smoother . But now that I have changed the clutches the bike has a horrible bog.It literally just falls on its face when you let go of the clutch from 10000 rpm .Someone told me that I was not holding the clutch long enough so I held it longer and it didn't bog as bad but it still bogged and it killed my 60ft time. Any ideas on how to fix it Or should I just go back to my 2011 clutches ?
It sounds to me like the 2005 clutch is hooking up quicker and has a lot less slip. I would say a gear change will be needed to now work with the new clutch.
 

·
Registered
Joined
·
639 Posts
Most guys run the gen 1 clutches without issues. Did you do the brocks clutch mod to get rid of the slipper and what clutch springs are you running? What RPM are you launching and how long are you slipping the clutch?

Seems like a lot of guys launch pretty high on the gen 4's, myself included. I seem to be around the 8-10kish range but my 60's really aren't that great. I've read and been told by guys faster than me you want to be 100% throttle as quick as you can and generally want to slip the clutch about to the tree then be out of it.

A video might help people listen and see what the bike is doing to offer help.
 

·
Registered
Joined
·
51 Posts
Is your bike stretched?
I run a gen4 swb
I tried gen1 clutch kit and didn't like it. Then I tried the gen4 with brocks extra disc and springs and still didn't like it.
Finally I went back to stock gen4 clutch, gen4 springs and gen1 retainers.
My best 60ft is 1.584
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
It's A 12 over stretch with 15 front and 43 rear sprocket And no I do not have the Brock mod clutch.After I posted this I did realize my Cam chain tensioner was Extreamly loose I wonder if that's what caused the problem too? It has since been fixed but I haven't raced it yet
 

·
Registered
Joined
·
639 Posts
I wouldn't think the cam chain tensioner would change how the bike launched.

Even with bad launches that thing runs 8.88s? Guess what kind of 60' are you cutting?
 
1 - 7 of 7 Posts
Top