Kawasaki ZX-10R Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
A plea for help! :notworthy:

Hello All
I scanned through the forums to see if I could find anything and came up empty. My bike is throwing the 46 code for the fuel pump relay stuck on. I replaced the fuel pump relay though and it still gives me the same code, and I can hear the fuel pump never shuts off.
Any advice on what I need to do next? I don't post much but I look to you all for all my technical issues and have never been steered wrong. Any help would be appreciated. Thanks in advance.

no1speshal

2007 ZX10R Special Edition
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Thanks Siwa. I hadn't thought the ECU would need to be cleared. I kind of thought it would do that on its own! I will see what I can find out about clearing codes and report back. Thanks again for the help!

no1speshal
 

·
REPOST Enforcement Mod
Joined
·
13,630 Posts
Well, the ECU will clear the code itself when the issue is corrected. There's no way to manually clear the fault in the ECU. So I think you still have the issue.

How did you replace the relay? The fuel pump relay is inside the relay box. It's not a separate piece. So did you replace the entire box?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Hi SkyDork. Yes, I replaced the entire box. Is it common for these to go bad? Maybe I just got a bad one straight off the bat. I am jonsin' to ride again so any and all help is appreciated. Thanks for chiming in!

no1speshal
 

·
REPOST Enforcement Mod
Joined
·
13,630 Posts
Hi SkyDork. Yes, I replaced the entire box. Is it common for these to go bad? Maybe I just got a bad one straight off the bat. I am jonsin' to ride again so any and all help is appreciated. Thanks for chiming in!

no1speshal
No, they're not prone to failure. Especially if you put a new relay box on there and not a used one.

Have you checked the circuit according to the manual? It may be a grounding issue to the pump that is causing it to run an bypassing the relay all together. Gonna take some investigation with a meter. It may be the ECU that's faulty also, but not likely.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
FML - Losing battle

No, they're not prone to failure. Especially if you put a new relay box on there and not a used one.

Have you checked the circuit according to the manual? It may be a grounding issue to the pump that is causing it to run an bypassing the relay all together. Gonna take some investigation with a meter. It may be the ECU that's faulty also, but not likely.
-----------------

Thank you SkyDork
I have new, but similar, issues as before now.

Here's the Update:
So, I had to put my bike in storage while I sold my house and bought another one. I finally took my bike out of storage and decided to take it to a shop. Something I have never done before, and ultimately a big mistake because I chose the wrong shop. The damage that shop has done to my bike is outrageous. When the [email protected]$$ at that shop found out I did not want them to fix my bike and that I was coming to pick up my bike, he literally ripped a handful of wires, about 10 from the three plugs feeding the fuel pump relay box, ripped out the fuse box, broke the mirrors, ripped the instrument cluster out, along with a handful of some other crap.
So far to the tune of around $2500. Yeah. Law suits filed and everything. Now I am back to trying to fix it myself again.

Now that I am back to the fuel pump relay, does anyone have a picture of the wire colors and which plugs they go into on the connectors? I have bought new connectors from Kawasaki, and new pins to terminate the wires. Although I can read a schematic, the schematics in the repair manual do not have a good depiction of 'where' each wire is in its respective plug. I am close, but I need a few more wires to be terminated before I can add the battery. Anything as simple as a picture of the plugs in place with the wire colors visible. Or, a schematic that has the wires and which plug, and location, they go. Honestly, at this point, anything would be a tremendous help.

What's in it for you? MONEY!!! :dollarbill: (I swear to god I will pay you - I'm sick of my bike being dead!)

I will send $20 via PayPal to anyone that will send me pictures that show what wire goes into what pin on each connector.
I will send $100 via PayPal to anyone that can help me successfully diagnose why the fuel pump would not shut off, as I expect once I get the wiring back in order, the same issue as before will return.
 

·
REPOST Enforcement Mod
Joined
·
13,630 Posts
-----------------

Thank you SkyDork
I have new, but similar, issues as before now.

Here's the Update:
So, I had to put my bike in storage while I sold my house and bought another one. I finally took my bike out of storage and decided to take it to a shop. Something I have never done before, and ultimately a big mistake because I chose the wrong shop. The damage that shop has done to my bike is outrageous. When the [email protected]$$ at that shop found out I did not want them to fix my bike and that I was coming to pick up my bike, he literally ripped a handful of wires, about 10 from the three plugs feeding the fuel pump relay box, ripped out the fuse box, broke the mirrors, ripped the instrument cluster out, along with a handful of some other crap.
So far to the tune of around $2500. Yeah. Law suits filed and everything. Now I am back to trying to fix it myself again.

Now that I am back to the fuel pump relay, does anyone have a picture of the wire colors and which plugs they go into on the connectors? I have bought new connectors from Kawasaki, and new pins to terminate the wires. Although I can read a schematic, the schematics in the repair manual do not have a good depiction of 'where' each wire is in its respective plug. I am close, but I need a few more wires to be terminated before I can add the battery. Anything as simple as a picture of the plugs in place with the wire colors visible. Or, a schematic that has the wires and which plug, and location, they go. Honestly, at this point, anything would be a tremendous help.

What's in it for you? MONEY!!! :dollarbill: (I swear to god I will pay you - I'm sick of my bike being dead!)

I will send $20 via PayPal to anyone that will send me pictures that show what wire goes into what pin on each connector.
I will send $100 via PayPal to anyone that can help me successfully diagnose why the fuel pump would not shut off, as I expect once I get the wiring back in order, the same issue as before will return.
Well, isn't he a pisser. :puter::eek::eyecrazy:

I don't have my G2 any longer, so no pics from me. But I do still have the wiring diagram! Do you have the service manual? That's invaluable!
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
-----------------

Thank you SkyDork
I have new, but similar, issues as before now.

Here's the Update:
So, I had to put my bike in storage while I sold my house and bought another one. I finally took my bike out of storage and decided to take it to a shop. Something I have never done before, and ultimately a big mistake because I chose the wrong shop. The damage that shop has done to my bike is outrageous. When the [email protected]$$ at that shop found out I did not want them to fix my bike and that I was coming to pick up my bike, he literally ripped a handful of wires, about 10 from the three plugs feeding the fuel pump relay box, ripped out the fuse box, broke the mirrors, ripped the instrument cluster out, along with a handful of some other crap.
So far to the tune of around $2500. Yeah. Law suits filed and everything. Now I am back to trying to fix it myself again.

Now that I am back to the fuel pump relay, does anyone have a picture of the wire colors and which plugs they go into on the connectors? I have bought new connectors from Kawasaki, and new pins to terminate the wires. Although I can read a schematic, the schematics in the repair manual do not have a good depiction of 'where' each wire is in its respective plug. I am close, but I need a few more wires to be terminated before I can add the battery. Anything as simple as a picture of the plugs in place with the wire colors visible. Or, a schematic that has the wires and which plug, and location, they go. Honestly, at this point, anything would be a tremendous help.

What's in it for you? MONEY!!!
(I swear to god I will pay you - I'm sick of my bike being dead!)

I will send $20 via PayPal to anyone that will send me pictures that show what wire goes into what pin on each connector.
I will send $100 via PayPal to anyone that can help me successfully diagnose why the fuel pump would not shut off, as I expect once I get the wiring back in order, the same issue as before will return.
Well, isn't he a pisser. <a href="http://Zx-10r.net/forum/images/smilies/smilies/puter.gif" border="0" alt="" title="puter" >:)</a><a href="http://Zx-10r.net/forum/images/smilies/smilies/icon_eek.gif" border="0" alt="" title="Eek" >:)</a><a href="http://Zx-10r.net/forum/images/smilies/smilies/eyecrazy.gif" border="0" alt="" title="Eyecrazy" >:)</a>

I don't have my G2 any longer, so no pics from me. But I do still have the wiring diagram! Do you have the service manual? That's invaluable!
-----------------------

I have the wiring diagram but it doesn't show the pin number and wire color in the same diagram. Thanks, though. Someone sent me a text, I may have it sorted! Hooray! Thanks!

no1speshal
 

·
Registered
Joined
·
4 Posts
having same issue

So how did u fix issue? my bike isthrowing a 46 code this is the 3rd time it was just a skint wire once the 2nd time i couldn't tell u but I went through harness and tapped everything thatit could possibly be? please help I was selling it both times! just attempts to crank this time it ran for a while and when I cut off it never would crank again.!~
 
1 - 11 of 11 Posts
Top