Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just bought 05 ZX10. When I am stuck in traffic on warm days temps don't take long to get high. Jumps up to 115 C and starts flashing and depends how long sitting at a light right up to 118 then flashes HI. I get moving cools down to 110-114 , but won't take a few minutes to back up. Fan kicks on at 90 but doesn't do much. Here's the best part. Replaced rad cap first...no change...flush and fill with good bike coolant ..no change...bike shop replaced thermostat...they bench tested it said was fine now..I trust this bike shop. First day in warm traffic...ZERO change. Still hit high numbers and flashing temps. Suggestions??
 

·
Registered
2018 ZX10R SE
Joined
·
1,008 Posts
Try changing out the hoses and rad, 20km or not it's a gen 1, it has been chilling a long time man, probably have corosion and or build up in the get down. Change your oil too. But unless you are somewhere it freezes, skip the antifreeze and rock water wetter or similar by vp etc. I ran the VP branded stuff and noticed a marked difference over stock coolant. Just that and distilled water will do it. In a pinch you could try a diluted vinegar flush. Just add about a cup of vinegar and run it through the bike for a few min. Then you need to flush the shit out of the coolant system. Chance u get some chunks of white shit coming out, may fix your issue. If you leave it too long it can etch lil pits in the rad so you don't want to get crazy with it. But if your bike is flashing hi that shit is no good. Will cost you tons more if you don't get it fixed asap
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I flushed and filled it twice now. Got coolant from the bike shop for bikes in her. I was inspecting my rad and definitely seen few fins bent but not sure if it would be the issue. Might go with me rad but might check my water pump too. Definitely hates slowing down and sitting in traffic
 

·
Registered
Joined
·
33 Posts
Changing coolant from factory could cause build up when the two different coolants interact - it may be that its had various coolant types ran through...
 
1 - 7 of 7 Posts
Top