Kawasaki ZX-10R Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys. I jut bought a 2004 zx10 and I’m having a problem with it. I can start it and it will sit there and idle no problems. Then when I go to rev it up and just wants to cut out on and off. So I turned it off. Took the fuel pump out and found that was real dirty so cleaned it all up and the tank put back together and put some sea foam in it and took it for a drive. And it still doing the same thing. If you go to crack on it it just like you shut the thing off. And then eas the throttle off and it till cut in and out. Barry can get to 90 Kms. Anyone else. Ever have this problem.? Things to check ?
 

·
Registered
Joined
·
98 Posts
Hey guys. I jut bought a 2004 zx10 and I’m having a problem with it. I can start it and it will sit there and idle no problems. Then when I go to rev it up and just wants to cut out on and off. So I turned it off. Took the fuel pump out and found that was real dirty so cleaned it all up and the tank put back together and put some sea foam in it and took it for a drive. And it still doing the same thing. If you go to crack on it it just like you shut the thing off. And then eas the throttle off and it till cut in and out. Barry can get to 90 Kms. Anyone else. Ever have this problem.? Things to check ?


Pain in the ass but check your spark plugs, they tell a story.


Sent from my iPad using Tapatalk
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top