Kawasaki ZX-10R Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
I bought a 14' zx10r with a r77d 3/4 slipon. Since the o2 sensor is no longer there does or should the bike have ECU reflash and/or bazzaz/pc5?
Also is there anyway to tell if my ECU has been reflashed?
I bought bike used with 109 miles from a car dealer that took it in on a trade so they don't have any info on it?

Thanks.
 

·
Registered
Joined
·
69 Posts
I bought a 14' zx10r with a r77d 3/4 slipon. Since the o2 sensor is no longer there does or should the bike have ECU reflash and/or bazzaz/pc5?
Also is there anyway to tell if my ECU has been reflashed?
I bought bike used with 109 miles from a car dealer that took it in on a trade so they don't have any info on it?

Thanks.
Gen 4 zx-10 in US didn't came with an O2 sensor. Please have a look to the servo motor too. If it's in place and when you turn the key on it works, so the ecu it's unflashed pretty much at 100%. If the servo it's not in place and nothing is connected (servo buddy o similar) and the FI light is off, so the ecu is flashed. If you have a servo buddy try to disconnect it and watch for the light. On, unflashed (almost sure), OFF flashed ecu (maybe the bike has been flashed to a later stage and the servo buddy has been kept in place but it wasn't needed more).
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top