Kawasaki ZX-10R Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi there, my ZX10R isn't revving past 11k rpm, I've cleaned the fuel mesh filter, cleaned any obstruction in the air inlet channel and disconnected the exhaust butterfly cables and it didn't made any difference. I've noticed some rattling over the cam tensioner but I've not read anywhere about it influencing the revs, so I don't think it may be the cause either. Does anyone have any idea what it could be?

Thanks

Enviado do meu ONEPLUS A5000 através do Tapatalk
 

·
Registered
Joined
·
766 Posts
1. make sure you attached the fuel line properly. You might not have pushed it all the way onto the tank outlet tube thingy before using the red clip to secure it.
2. make sure you route the braided fuel line so that it isn't being pinched when you put the tank back on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Yesterday I tried readjusting the cam tensioner but it got too tight and it started whining, so I rushed back home and didn't risked triyng to rev as much as needed to verify if the revs would go up till where they where supposed to. I'll readjust the tensioner later today and check that gas hose you mentioned.

Enviado do meu ONEPLUS A5000 através do Tapatalk
 

·
Registered
Joined
·
766 Posts
It's most likely fuel related. The older members here aren't answering because this problem has come up many times before with the 4th Gen and the forum is littered with newbies starting threads asking why their engine won't rev past 8500rpm (pinched fuel line) or 11,000rpm (improperly connected fuel coupler).

I'm surprised nobody's scolded you for not using the search function but I get that it would be difficult to pick the right key words to find the relevant threads.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Well, fuel was my guess since the beginning, and as surprising as it must sound, it was, a freaking pinched fuel line, that simple.. I feel stupid, but then again, a lot of times the simplest problems are the ones we most happen to bypass. Thanks for the answer, it was in fact completely helpful.

Enviado do meu ONEPLUS A5000 através do Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
My first thought was the fuel pump, but it was just a pinched line.

Enviado do meu ONEPLUS A5000 através do Tapatalk
 

·
Registered
Joined
·
766 Posts
Success! Good to hear you got the fuel issue sorted. Since you're new here why don't you post some nice pics of your ride? It makes me sad that we don't have more glamour shots of member's bikes on the forum. I've uploaded very few myself but my bike is always dirty and I'm a crappy photographer.
 
1 - 8 of 8 Posts
Top