Kawasaki ZX-10R Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello I got a 08 zx10 with low miles under 1800 someone has been in the starter cultch there is some gasket Sealant around the edges the bike never started on the first try bought a bazzaz box had it tuned ran nice then went for a good ride then the bike seems to be losing power took it to the dealership for the recterfire recall asked to run it on the dyno they called me and said motor is noisy so they stop I hear a ticking on the right side not on the left need help pleas
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,697 Posts
Hello I got a 08 zx10 with low miles under 1800 someone has been in the starter cultch there is some gasket Sealant around the edges the bike never started on the first try bought a bazzaz box had it tuned ran nice then went for a good ride then the bike seems to be losing power took it to the dealership for the recterfire recall asked to run it on the dyno they called me and said motor is noisy so they stop I hear a ticking on the right side not on the left need help pleas
Welcome!

Recterfire....I literally did this :spit:when reading that. Funniest shit I've read in awhile.

FYI - rectifier.

Check the CCT first thing as mentioned. But it would help to know whether the noise is coming from the clutch area, head area, timing rotor area, etc, etc. It it a ticking noise? Thumping? Rhythmic with the engine RPM? Static? Can't really help without some more details.
 
1 - 3 of 3 Posts
Top