Kawasaki ZX-10R Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
hey just got back in from work today, bike ran fine this morning, idles fine, on pulling away it is down on power then bogs down at about 5krpm till it hits 6k then it cracks on as normal.

fuel pump is running fine as far as i can tell, no misfire or backfire etc any idea's ?

fuel filter ?

any idea's, first dry night in a long time and it lets me down :(

deppressed biker :(
 

·
Registered
Joined
·
61 Posts
Is the FI light coming on at all when it does this?
 

·
Registered
Joined
·
61 Posts
With out a FI light coming on it could be any number of things and a little harder to track down. I would be leaning to fuel filter, fuel pump, or maybe a loose connection somewhere.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #6
bike is used daily, filled up fuel two days ago, bike is garaged at night or when not in use, it is parked outside when im at work but is for the most part protected from the weather/rain by the building.

fuel pump cycles as normal on turning ignition on and appears to be pumping away as normal when running
 

·
Registered
Joined
·
61 Posts
Could it be a possiblity that maybe the gas tank isn't venting properly and this is causing the issues?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #9
knowing my luck it could any and all of the above lol

gotta get me some sleep now and ill get a fresh start in the morning :)

many thanks for your input gents :)
 

·
Registered
Joined
·
48 Posts
Discussion Starter #10
update

checked fuel for water/debris, all clear, checked fuel pump flow, all good again

edit: checked venting on tank, all good

was serviced a couple weeks back, but checked air filter etc, all good

however what i did notice yesterday morning was the throttle/cable assembly top screw was loose bottom one was working its way to being totaly loose, stripped/lubed cables, reassembled, then tested thoroughly for 2 hours before i started work :helmet:

all seems to be in working order, power delivery back to normal :mrgreen:

thanks for the help :cool:

stevie
 

·
Dont mess wit White Ninja
Joined
·
5,932 Posts
So basically it came down to be a loose throttle cable :lol:

Hey man, better that than anything!
 
1 - 12 of 12 Posts
Top