Kawasaki ZX-10R Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,361 Posts
Discussion Starter #1
anyone got 06-07 throttle bodies off. need part # on primary shaft tps sensor, any help appreciated.
 

·
Bloo Moderator
Joined
·
23,742 Posts
anyone got 06-07 throttle bodies off. need part # on primary shaft tps sensor, any help appreciated.
Wonder if they use the same part #s for 1st Gen? Does the fiche not show what your looking for on Ronayers.com or kawasaki.com? I have first Gen Throttle boddies (spare throttle body) I can look for part #s on that. :dontknow:


bloo
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #3
might help bloo. trying to avoid a mixup between sec. and primary tps sensor, did some work on a set and milled and blended shaft and radiused flies. got stupid and lost notes. i would appreciate it.
 

Attachments

·
Bloo Moderator
Joined
·
23,742 Posts
secondary TPS for 1st Gen is Mikuni 214X26

bloo
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #5
different, but thanks for help. one sensor has #'s 5008c and 08168, other is 5008 and 8566a. sec. #'s are difficult to read . help me out guys. thanks.
 

·
Bloo Moderator
Joined
·
23,742 Posts
different, but thanks for help. one sensor has #'s 5008c and 08168, other is 5008 and 8566a. sec. #'s are difficult to read . help me out guys. thanks.
Not sure where you are getting those #s my Primary is Mikuni 034X27 the only differance from my Sec. to Primary Sensor I suspect is the Connector at the ends. As you probably know they TBs must be bought with sensors in place so again not sure where you got those other #s :dontknow:.....sorry I couldn't help but if anything though another :bump: for ya :wink:
 

·
Registered
Joined
·
1,802 Posts
different, but thanks for help. one sensor has #'s 5008c and 08168, other is 5008 and 8566a. sec. #'s are difficult to read . help me out guys. thanks.
They are different colors also right. ONe is grey the other is Black. I have a set of 07' zx10r Tb's on my 03' z1000.

This is what I got.
Black sensor is the front main TPS it is connected to the throttle cable itself. Part number is 5008/2986a I think.
Grey Sensor is the secondary ones. I removed the rod and everything else but it keeps the FI light from coming on.
Part number is 5008C / 2586A Or something really close to it.
 

·
Registered
Joined
·
1,802 Posts
Here are a few pics

My injectors are on top but the sensor position will be the same.
 

Attachments

·
Registered
Joined
·
1,802 Posts
thats what i needed patrick. photos are great. appreciate u and bloo.
:thumbsup:
Not a problem.. Glad to help when I can.
 
1 - 11 of 11 Posts
Top