Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,248 Posts
Discussion Starter #1
I'm not sure where the original post concerning this issue went to (titled "anyone else have this problem", I think), but nevertheless there have been a few of us 06 owners which have had issues with the rear undertail plastic piece "popping out" just under the tail light. Below are some of the original pics I posted illustrating this very issue on my bike.







....so while I had my bike in for it's 4k mile service today, I had my dealership look at it, and they immediately ordered a new undertail plastic piece under warranty. I realize that other 06 owners have been able to simply "snap" their plastic piece in place, but in my case the rear locking tab was actually broken. The new plastic piece will more than likely "pop out" on me again after another 4k miles or so, but if we don't start somewhere and bring this issue to Kawi's attention, it may very well never get properly resolved. :headshake

D
 

·
Registered
Joined
·
2,248 Posts
Discussion Starter #2
Had my undertail plastic piece replaced yesterday under warranty. Everything looks nice and "tucked in" now. Here's hoping that it'll stay that way.... :headshake

D
 

·
Registered
Joined
·
1,018 Posts
Glad you got your issue fixed without any qualms from the dealership. It's a common problem and it seems like the plastic will pop loose every time you hit a large bump.
 

·
Registered
Joined
·
2,248 Posts
Discussion Starter #4
brian0128 said:
Glad you got your issue fixed without any qualms from the dealership. It's a common problem and it seems like the plastic will pop loose every time you hit a large bump.
If you take your passenger seat off, and look at the rear hook that's holding the plastic piece "up" in the "area of offense," said hook is holding on by it's "fingernails" so to speak. If the hook actually extended futher onto the mating surface, I think it would hold better.... :headshake

D
 

·
Registered
Joined
·
3,449 Posts
It was a simple fix for mine, I saw it when installed my fender eliminator I just hook the clip and push the rear fender in. Curiosity ask the dealer for the 06 they said most of the were like that.
 

Attachments

·
Registered
Joined
·
2,248 Posts
Discussion Starter #6
kawi1000 said:
It was a simple fix for mine, I saw it when installed my fender eliminator I just hook the clip and push the rear fender in. Curiosity ask the dealer for the 06 they said most of the were like that.
Yup, I actually loosened my top plastic piece when I got my bike back from the dealership, and pushed in on it a bit before re-tightenting the 4 screws. It may have given the hook a little more grip, but not much... :headshake

D
 

·
Registered
Joined
·
54 Posts
brought mine to dealer too. and gave too much bs. i saw were the problem is. re snapped the tab on undertail. fixed the problem..
 

·
Registered
Joined
·
465 Posts
Mine was popped out, I snapped back on, holding so far..:dontknow:
 

·
Registered
Joined
·
2,091 Posts
blackisfaster said:
Mine was popped out, I snapped back on, holding so far..:dontknow:
What he said
 
1 - 10 of 10 Posts
Top