Kawasaki ZX-10R Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My zx10r has been through a lot over the past 4 years and i recently noticed that it was pulling to the right. Ive got an alignment like 4 months ago and just put some new set of perelli's yestureday and today i started to break them in and noticed my bike would pull to the right on a cost with my hands of the controls. I got my tires and got them mounted from cycle gear.
IF possible i would like to know how to adjust this problem myself.
ANY HELP IS APPRECIATED.
 

·
Registered
Joined
·
265 Posts
tires are probably on right, pretty hard to f--k up. but you never know... have you hit anything? bent a fork in the past? anything? alright.. assuming the answer is NO to the above questions and anything connected to them you can think of.. pull off both rims, as you do note any bolts that are overtightened(do yourself the favor and buy your stands and do it with a service manual, or at LEAST take it do a different shop then the one who did your "alignment" cause srsly.. alignment? anyway.. take off both rims, make sure all the bolts are tensioned correctly, the axels are straight and lubed, the bearings in properly and lubed, and theres no drag from the brakes, wich you can feel if there is after riding by seeing if they are hot(dont get burned)

theres only FOUR compenents to moto steering, 1=throttle(OUT) 2=straight frame/forks(been down?) 3=drag(axels,bearings,spacers,brakes) 4=YOU, make sure your not somehow magically leaning one way, have a buddy confirm w/o telling him wich direction it leans. and make sure it doesnt do the same on his bike. personally, i put more pressure on my left then my right foot, had no idea till about a week ago was doing standup wheelies on a buddies little 50 and fell left everytime.
i didnt even list tires, never had a problem, unless youve got some used track rubber on there its highly highly unlikely.

good luck let us know any more info.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Soo It turned out to be my clutch cable that was making it pull hard to the right and now it just pulls a little but I don't think I can loosen the throttle cables. Thanks for the help guys.
 
1 - 3 of 3 Posts
Top