Kawasaki ZX-10R Forum banner

stator

  1. Performance and Tech
    Need your help diagnosing issues on a 2006 zx10r. I experienced starting issues and thought I had a bad battery, so I replaced it with a new one, but the problems persisted. I realized the battery was not getting charged, so I contacted the local dealer and they informed me the stators on gen2s...
  2. The ZX-10R
    I have a zx10 2007 that ive been riding for a yr now....when i take short trips the battery seems to weaken where ultimately i need to charge it and its fine temporarily....well i parked it in the garage for a month and now when i charge the battery i dont get any power to gauges headlights or...
  3. General Motorcycle Discussions
    I need help my regulator was bad I tested it then replaced it now its good. Now when im riding my guages go out then Rpms drop and it wont start my battery tests good on/off and the voltage drop with ignition is good it also holds charge while running. When im riding my guages go out then, with...
  4. Parts, Gear and Accessories
    Parting out my engine- crank went out and took the cases with it. Bike had just over 10,000 miles and ran great. Here is whats left, all prices are shipped within the 48. Complete Head- $150 With both cams, all internals, tappet cover, plug wires. One intake boot is a little mangled- would...
  5. The ZX-10R
    Thanks in advance for the replies. I recently installed my stator but in the rush i was in i installed it upside down. So the wires had been cut through completely and never worked. On to my question. I can repair these wires but i am wondering the best way to do it? 1. Solder? then heat...
  6. The ZX-10R
    without wanting to bore anyone to death I will try and keep it short, however I am practically on my knees begging for help to get this resolved. In Jnauary this year I took my beloved ZX10R out for a spin and cracked the head and did untold amounts of damaged to the head bottom ends and so...
Top