Kawasaki ZX-10R Forum banner
electrical
1-5 of 5 Results
  1. The ZX-10R
    Hi all, I had a bit of a search and couldn't find anything about this in here, so apologies if the same issue is elsewhere. I've recently picked up a 2011 ZX10R (ABS) and I'm having some kind of weird electrical issue. I had a few short/moderate rides on it, then despite not having any issues...
  2. The ZX-10R
    Hey guys new to the forum, I recently purchased a 08 zx10 and while riding it the bikes gauge pack just completely turned off then shortly after it began to misfire and die leaving me stranded. I initially thought the battery was bad since it was slow cranking when i bought it so I replaced and...
  3. Performance and Tech
    So I bought my 05 zx10 in January off a guy after it was stripped for parts outside his shop one night (assholes) when I bought it, he started it right up and ran. I'm in the process of converting it to a streetfighter. I went to start it up last week, hit the starter and the relay started...
  4. The ZX-10R
    Good day every one. This is my first post and I just wanted to say hi to the community. I just bought a 2010 zx10r with only 300 miles on it. I have put about 200 miles on this baby no problem. A few days ago I let a friend of mine remove the mirrors. He just sniped the turn signal wires and...
  5. The ZX-10R
    I noticed on my 05 zx10 that it was having a hard time starting and stay running. As in it didnt have enough juice. I replaced the battery and it started fine, but as soon as I let go of the starter button, it dies. I noticed that even after it was turned off and the key was out of the...
1-5 of 5 Results
Top