Kawasaki ZX-10R.net - Reply to Topic
Thread: Gen 3: 2008-2010 Subthrottle Actuator Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-02-2019 07:01 PM
Billy13
Quote:
Originally Posted by Kawasaki Brad View Post
I was referring to the top butterflies.
We don't have top ones they where already removed. I have already recieved a new TB but will hold on to this one and try it later.
05-31-2019 11:58 AM
Kawasaki Brad I was referring to the top butterflies.
05-30-2019 11:46 AM
Billy13
Quote:
Originally Posted by Kawasaki Brad View Post
Need a new tb assembly. Can't replace.

Engine won't run without it (or won't run worth a s#!t even if it does) because secondary butterflies are fully closed in their "off" position.

You can remove the flaps. Engine will run fine if they're gone completely. Will throw a code but won't limp mode.
Is that the top butterflies or bottom butterflies? We run with our top ones closer to breather removed. But I did order a new TB last night.
05-30-2019 11:21 AM
Kawasaki Brad Need a new tb assembly. Can't replace.

Engine won't run without it (or won't run worth a s#!t even if it does) because secondary butterflies are fully closed in their "off" position.

You can remove the flaps. Engine will run fine if they're gone completely. Will throw a code but won't limp mode.
05-29-2019 03:37 PM
Billy13
Subthrottle Actuator

Mine broke is that something that I can replace...manual says factory set... or do I need a new throttle body assembly or can the motor be ran with it unplugged.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome