Kawasaki ZX-10R.net - Reply to Topic
Thread: Gen 1: 2004-2005 First Post Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-05-2014 10:47 PM
ls1leadfoot Tasteful changes my friend

Welcome !!!!
08-04-2014 10:33 PM
keithk Beautiful!!!!!!!!!!!!! Gen1 ftw!
08-04-2014 09:56 PM
ND4SPD Thanks for the warm welcome SkyDork. Yeah, Baxley is right next door and this is my piece of Kawi green!
08-04-2014 09:51 PM
ND4SPD Thanks TechX, much appreciated.
08-04-2014 12:05 PM
SkyDork Welcome to the party!

You're the only other person I've seen with a green Baxley chick like mine. Dig it!


Sent from Motorcycle.com App
08-03-2014 07:06 PM
TechX Very nice.
08-03-2014 06:37 PM
ND4SPD
First Post

Greetings All,

I've been lurking around for quite awhile learning how to navigate the forum and locate information. I learned early on the power of the search button and the wealth of information available. I purchased an 05 this past year with only 3500 mi. With the help of this forum, i set forth upgrading this already stellar platform. The majority of these upgrades were made to the suspension and brakes. The rest were focused around the valve train and controls. I have attached before/after photographs. I wanted to express my thanks to this forum for helping me get my bike up to par.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome