It doesn't get better - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-13-2013, 02:47 PM Thread Starter
GP Star
 
Tech5's Avatar
 
Join Date: Oct 2008
Location: Atlanta,GA
Posts: 3,385
Posting Frequency
       
Garage
Tech5 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-13-2013, 03:30 PM
Of course you are faster
 
Rifleman's Avatar
 
Join Date: Mar 2005
Location: Chicago area
Posts: 2,062
Posting Frequency
         
It came to be known as the "Farkus" incident.



Need to know how to install your Rifleman's 1/5th throttle insert? click me
For more info on a sticky grip (not enough cable slack) click me
And another amazing install write up click this

Quote:
Originally Posted by Rifleman View Post
lol, once you go 1/5th... you NEVER go back
Rifleman is offline  
post #3 of 3 Old 09-13-2013, 03:36 PM Thread Starter
GP Star
 
Tech5's Avatar
 
Join Date: Oct 2008
Location: Atlanta,GA
Posts: 3,385
Posting Frequency
       
Garage
Quote:
Originally Posted by Rifleman View Post
It came to be known as the "Farkus" incident.

The Truth
Tech5 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Well.... This doesn't look right.. codyc_13 Performance and Tech 7 04-01-2011 10:49 AM
Gen 2: This doesn't sound good... txfence Performance and Tech 6 03-23-2011 03:09 AM
08 DOESN'T pull right anymore... jasonmark1993 Performance and Tech 1 01-06-2011 08:42 AM
Battery doesn't get charge sladkixxx The ZX-10R 29 03-22-2009 12:55 AM
Horn Doesn't Work JP636 Performance and Tech 4 11-25-2008 05:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome